Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an ESXi 5 host (free) and vSphere Client. I would like to update to u1 but I cannot find the way to do it. Updates are ZIP files with modules in it; no installer. vSphere client doesn't have an update module.

Thanks!

[edit]

/vmfs/volumes/4f255b5c-6acfd348-d53c-00e04c68ee7a/esxi_update # esxcli software vib install -d /vmfs/volumes/4f255b5c-6acfd348-d53c-00e04c68ee7a/esxi_update/update-from-esxi5.0-5.0_update01.zip
 [InstallationError]
 [Errno 32] Broken pipe
       vibs = VMware_locker_tools-light_5.0.0-1.11.623860
 Please refer to the log file for more details.
/vmfs/volumes/4f255b5c-6acfd348-d53c-00e04c68ee7a/esxi_update # esxcli software vib install -d /vmfs/volumes/4f255b5c-6acfd348-d53c-00e04c68ee7a/esxi_update/update-from-esxi5.0-5.0_update01.zip
 [InstallationError]
 [Errno 32] Broken pipe
       vibs = VMware_locker_tools-light_5.0.0-1.11.623860
 Please refer to the log file for more details.
/vmfs/volumes/4f255b5c-6acfd348-d53c-00e04c68ee7a/esxi_update # esxcli software vib install -d /vmfs/volumes/4f255b5c-6acfd348-d53c-00e04c68ee7a/esxi_update/ESXi500-201205001.zip
 [InstallationError]
 [Errno 32] Broken pipe
       vibs = VMware_locker_tools-light_5.0.0-1.12.653509
 Please refer to the log file for more details.

[edit]

"install" -> "update"

Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.

    /vmfs/volumes/4f255b5c-6acfd348-d53c-00e04c68ee7a/esxi_update # esxcli software vib update -d /vmfs/volumes/4f255b5c-6acfd348-d53c-00e04c68ee7a/esxi_update/update-from-esxi5.0-5.0_update01.zip
Installation Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed: VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.500.1.11.623860, VMware_bootbank_esx-base_5.0.0-1.11.623860, VMware_bootbank_misc-drivers_5.0.0-1.11.623860, VMware_bootbank_net-e1000e_1.1.2-3vmw.500.1.11.623860, VMware_bootbank_net-nx-nic_4.0.557-3vmw.500.1.11.623860, VMware_bootbank_sata-ahci_3.0-6vmw.500.1.11.623860, VMware_bootbank_sata-ata-piix_2.12-4vmw.500.1.11.623860, VMware_bootbank_scsi-aacraid_1.1.5.1-9vmw.500.1.11.623860, VMware_bootbank_scsi-megaraid-sas_5.34-1vmw.500.1.11.623860, VMware_bootbank_scsi-mpt2sas_06.00.00.00-6vmw.500.1.11.623860
   VIBs Removed: VMware_bootbank_ehci-ehci-hcd_1.0-3vmw.500.0.0.469512, VMware_bootbank_esx-base_5.0.0-0.7.515841, VMware_bootbank_misc-drivers_5.0.0-0.7.515841, VMware_bootbank_net-e1000e_1.1.2-3vmw.500.0.7.515841, VMware_bootbank_net-nx-nic_4.0.557-3vmw.500.0.0.469512, VMware_bootbank_sata-ahci_3.0-6vmw.500.0.0.469512, VMware_bootbank_sata-ata-piix_2.12-4vmw.500.0.0.469512, VMware_bootbank_scsi-aacraid_1.1.5.1-9vmw.500.0.0.469512, VMware_bootbank_scsi-megaraid-sas_4.32-1vmw.500.0.0.469512, VMware_bootbank_scsi-mpt2sas_06.00.00.00-5vmw.500.0.0.469512
   VIBs Skipped: VMware_bootbank_ata-pata-amd_0.3.10-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-atiixp_0.4.6-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-cmd64x_0.2.5-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-hpt3x2n_0.3.4-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-pdc2027x_1.0-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-serverworks_0.4.3-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-sil680_0.4.8-3vmw.500.0.0.469512, VMware_bootbank_ata-pata-via_0.3.3-2vmw.500.0.0.469512, VMware_bootbank_block-cciss_3.6.14-10vmw.500.0.0.469512, VMware_bootbank_esx-tboot_5.0.0-0.0.469512, VMware_bootbank_ima-qla4xxx_2.01.07-1vmw.500.0.0.469512, VMware_bootbank_ipmi-ipmi-devintf_39.1-4vmw.500.0.0.469512, VMware_bootbank_ipmi-ipmi-msghandler_39.1-4vmw.500.0.0.469512, VMware_bootbank_ipmi-ipmi-si-drv_39.1-4vmw.500.0.0.469512, VMware_bootbank_misc-cnic-register_1.1-1vmw.500.0.0.469512, VMware_bootbank_net-be2net_4.0.88.0-1vmw.500.0.7.515841, VMware_bootbank_net-bnx2_2.0.15g.v50.11-5vmw.500.0.0.469512, VMware_bootbank_net-bnx2x_1.61.15.v50.1-1vmw.500.0.0.469512, VMware_bootbank_net-cnic_1.10.2j.v50.7-2vmw.500.0.0.469512, VMware_bootbank_net-e1000_8.0.3.1-2vmw.500.0.7.515841, VMware_bootbank_net-enic_1.4.2.15a-1vmw.500.0.0.469512, VMware_bootbank_net-forcedeth_0.61-2vmw.500.0.0.469512, VMware_bootbank_net-igb_2.1.11.1-3vmw.500.0.0.469512, VMware_bootbank_net-ixgbe_2.0.84.8.2-10vmw.500.0.0.469512, VMware_bootbank_net-r8168_8.013.00-3vmw.500.0.0.469512, VMware_bootbank_net-r8169_6.011.00-2vmw.500.0.0.469512, VMware_bootbank_net-s2io_2.1.4.13427-3vmw.500.0.0.469512, VMware_bootbank_net-sky2_1.20-2vmw.500.0.0.469512, VMware_bootbank_net-tg3_3.110h.v50.4-4vmw.500.0.0.469512, VMware_bootbank_ohci-usb-ohci_1.0-3vmw.500.0.0.469512, VMware_bootbank_sata-sata-nv_3.5-3vmw.500.0.0.469512, VMware_bootbank_sata-sata-promise_2.12-3vmw.500.0.0.469512, VMware_bootbank_sata-sata-sil_2.3-3vmw.500.0.0.469512, VMware_bootbank_sata-sata-svw_2.3-3vmw.500.0.0.469512, VMware_bootbank_scsi-adp94xx_1.0.8.12-6vmw.500.0.0.469512, VMware_bootbank_scsi-aic79xx_3.1-5vmw.500.0.0.469512, VMware_bootbank_scsi-bnx2i_1.9.1d.v50.1-3vmw.500.0.0.469512, VMware_bootbank_scsi-fnic_1.5.0.3-1vmw.500.0.0.469512, VMware_bootbank_scsi-hpsa_5.0.0-17vmw.500.0.0.469512, VMware_bootbank_scsi-ips_7.12.05-4vmw.500.0.0.469512, VMware_bootbank_scsi-lpfc820_8.2.2.1-18vmw.500.0.0.469512, VMware_bootbank_scsi-megaraid-mbox_2.20.5.1-6vmw.500.0.0.469512, VMware_bootbank_scsi-megaraid2_2.00.4-9vmw.500.0.0.469512, VMware_bootbank_scsi-mptsas_4.23.01.00-5vmw.500.0.0.469512, VMware_bootbank_scsi-mptspi_4.23.01.00-5vmw.500.0.0.469512, VMware_bootbank_scsi-qla2xxx_901.k1.1-14vmw.500.0.0.469512, VMware_bootbank_scsi-qla4xxx_5.01.03.2-3vmw.500.0.0.469512, VMware_bootbank_scsi-rste_2.0.2.0088-1vmw.500.1.11.623860, VMware_bootbank_uhci-usb-uhci_1.0-3vmw.500.0.0.469512, VMware_locker_tools-light_5.0.0-1.11.623860
share|improve this question
add comment

4 Answers

up vote 8 down vote accepted

In order to update ESXi without vSphere, you will have to perform the update from the command line. That means enabling SSH and console access to the host and placing the update files on an accessible datastore.

The core command will be:

esxcli software vib update -d /vmfs/volumes/[DATASTORE]/[PATCH_FILE].zip

The guide here is also helpful...

http://www.chriscolotti.us/vmware/vsphere/how-to-patch-vsphere-5-esxi-without-update-manager/

share|improve this answer
1  
esxcli doesn't have to be ran from the command line on the ESXi host. You can install the remote-cli software, or download the remote-cli VM. –  Zoredache May 3 '12 at 17:47
    
should I only apply the latest (and skip update1)? –  Sirber May 3 '12 at 20:05
    
U1 fails with "[Errno 32] Broken pipe". trying the latest patch –  Sirber May 3 '12 at 20:10
    
change "install" with "update", then it works –  Sirber May 3 '12 at 20:19
add comment

One method is to update the system via the command line.

Grab the lastest package from here. As of today, that is ESXi500-201205001.

Transfering the update zip file to a datastore on that is visible to the host.

Use commands like the following to apply the update.

# check server status
vicfg-hostops --server servername --username root --operation info

# start maint mode (you should stop any running VMs)
vicfg-hostops --server servername --username root --operation enter

# examine upgrade package
esxcli --server servername --username root software sources profile list --depot=[datastore1]/ESXi500-201112001.zip

# perform a dry run of the upgrade
esxcli --server servername --username root software profile install --depot=[datastore1]/ESXi500-201112001.zip --profile=ESXi-5.0.0-20111204001-standard --dry-run

# perform the upgrade
esxcli --server servername --username root software profile install --depot=[datastore1]/ESXi500-201112001.zip --profile=ESXi-5.0.0-20111204001-standard

# reboot the server
vicfg-hostops --server servername --username root --operation reboot

# examine the system post update, to verify the update applied.
esxcli --server servername --username root software vib list

See:

The most recent vSphere Management Assistant appliance VM can be found here. This is a VM with the remote CLI package installed. The remote CLI package can be found here.

share|improve this answer
    
sorry, ewwhite's solution is simpler –  Sirber May 3 '12 at 20:48
1  
IMO, ewwhite is suggesting pretty much the same solution, he has just provided less context in his answer, and given you a method that only works from the console, making it someone annoying if you have several hosts to update. I included steps that would tell you how to see what is going on, and links to official reference material. –  Zoredache May 3 '12 at 20:57
add comment

There's an article that gives you the whole process: http://public.madeinengland.co.nz/how-to-update-esxi-5/

It's good because it uses the GIU so it's simpler. Also, it's better because it allows compliance view of outdated server parts

share|improve this answer
1  
The Update Manager package is included in vCenter, which is not free. –  Sirber Sep 6 '12 at 19:27
add comment

So you have vsphere installed, but haven't found the update utility. I'm still on v4.1 so maybe they got rid of this, but there should be an application called "vSphere Host Update Utility 4.0". Open this, it should detect the hosts on your network. Select the host to upgrade, click the "upgrade host" button. This takes the zip file you are talking about on the first page and will upgrade it for you.

share|improve this answer
    
They actually got rid of it with 4.1. –  Chopper3 May 3 '12 at 20:23
    
Wierd, I've had it for awhile now and we haven't upgraded yet. Odd that they would get rid of it so the only way you can do it is through cli. –  Adam Skoog May 3 '12 at 20:40
    
you have to buy vCenter to do it, or cli (free) –  Sirber May 3 '12 at 20:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.