Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem with a new install of a XenApp Citrix server.

Everything was working fine, but I was setting up Citrix Access Gateway and single sign in. Now, on the main server I am getting an error:

The licenses required by this edition of Citrix XenApp are not present on the license server CWP-CITRIX-02.

I have a fundamental license installed and as far as I can tell this is all set up and working fine because the second server in this farm is using the license server on this machine with no problems.

Not really sure where to go from here!

UPDATE:

Dan, thought it would be better to put the info you requested here:

There are two servers in the farm, CWP-CITRIX-02 and CWP-CITRIX-03.

CWP-CITRIX-02 is the master server, it hosts the license server.

I am running XenApp Fundamentals 6.0.

CWP-CITRIX-03 is currently working, I can launch applications which are hosted on this server, however any applications hosted on CWP-CITRIX-02 fail with the following error:

An error occurred while making the requested connection.

And qfarm /load shows:

CWP-CITRIX-02 - 20000 CWP-CITRIX-03 - 100

If you need any more information let me know.

Diagram

share|improve this question
1  
Hi, can you be a little clearer about your farm structure. What version of XenApp? What server is running the license service (And what version), what server works and what server doesn't. Also ensure that the second server is working fine by looking at License usage on the console. –  Dan May 4 '12 at 8:46
    
Dan, i have added what you requests to my original post as I probably should of included it in the original post and to make it clear to all. Thanks. –  boburob May 4 '12 at 9:14
    
Ah, in that case, you may be seeing this issue: support.citrix.com/article/CTX125363 (There are two other articles linked at the bottom which are worth exploring). The load of 20,000 is probably a symptom of your licensing issue and that's why you can't connect to the server using Citrix (A server with a load of 20,000 won't accept connections) –  Dan May 4 '12 at 9:30
    
Followed those steps through, didnt help. Cant telnet to the license server fine. Upgraded the license server to the latest version as well and still no help. –  boburob May 4 '12 at 12:51
    
Just noticed something. You can no longer RDP on to the box. When I looked further the license had expired, I have reissued this and it all seems to be licensed correctly, but you can still not RDP onto the server, it gets to the Welcome screen and just shuts. In the event log the only thing I see is the user being logged in and logged out. –  boburob May 4 '12 at 14:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.