Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've a problem about vsftpd server. I've created an vsftpd server with implicit ssl. It works perfectly with filezilla client on ubuntu 10.04, but when I run with filezilla client on windows, it got an error. The error was "GnuTLS error -12: A TLS fatal alert has been received."

This is the content of my vsftpd.conf

listen=YES
anonymous_enable=NO
local_enable=YES
write_enable=YES
dirmessage_enable=YES
use_localtime=YES
xferlog_enable=YES
connect_from_port_20=YES
secure_chroot_dir=/var/run/vsftpd/empty
pam_service_name=vsftpd
rsa_cert_file=/etc/vsftpd/vsftpd.pem
require_ssl_reuse=NO
ssl_enable=YES
implicit_ssl=YES
listen_port=990
force_local_data_ssl=YES
ssl_tlsv1=YES
ssl_sslv2=YES
ssl_sslv3=YES
strict_ssl_read_eof=YES

Anyone help me please.

share|improve this question
add comment

2 Answers

Try to comment implicit_ssl option and restart service.

#implicit_ssl=YES

"If enabled, an SSL handshake is the first thing expect on all connections (the FTPS protocol). To support explicit SSL and/or plain text too, a separate vsftpd listener process should be run." Ubuntu Manpages

share|improve this answer
    
Sorry for long time reply. I've tried it, but give me same result. How about that? –  Christoforus Surjoputro Jul 29 '12 at 17:52
add comment

vsftpd uses DES-CBC3-SHA by default which is not supported by Filezilla. Add the line

ssl_ciphers=high

to vsftpd.conf to solve the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.