Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When disabling users I typically will be asked to retain a copy of their mailbox. I accomplish this by literally creating their mailbox in Outlook and then exporting to PST. Is there some way around having to do this just to save a mailbox?

I've tried New-MailboxExportRequest but I keep getting the following after providing an alias:

Supply values for the following parameters:
FilePath: \\localhost\EXPORT_PST\myuser.pst
Mailbox: myuser

Couldn't find the Enterprise Organization container. <--- the error

I've also tried supplying as the mailbox as well.

Edit 2:

I had already seen the post at so I set the permissions as follows below:

NTFSNTFS permissions

SharingSharing permissions

I am still getting that error.

Final Solution

In Exchange SP2, it does not warn you that you have not set role assignments, it just fails. So be sure to create a management role for "Mailbox Import Export" and add your user to the group, then restart PowerShell for this to take effect.

share|improve this question
up vote 7 down vote accepted

In the Exchange Management Shell New-MailboxExportRequest

It will request a filepath, which is relative to the Exchange server holding the mailbox, and must be accessibly by the same user that the store.exe process is running as (typically the machine account). It will also ask for the Mailbox, specify by the alias.

You can get an update of what it's doing with Get-MailboxExportRequest; which can be piped to Get-MailboxExportRequestStatiscs for more details.

And cleanup after your export when it's done with Remove-MailboxExportRequest. It's usually best to run this as Remove-MailboxExportRequest -Status Competed so any failed or pending requests are left to run or be examined.

That error means that the Exchange Trusted Subsystem doesn't have read/write access to the path you specified.

Edit 2:
That error apparently can also be generated if you don't have permission to import/export. Check your Exchange Role and be sure you have those permissions. - Thanks to jshin47 for that.

share|improve this answer
I should have mentioned I tried New-MailboxExportRequest but kept failing with an error. I'll update my question. – tacos_tacos_tacos May 4 '12 at 15:26
You have to supply the Exchange Alias, this is not the username (though it can be the same) and not the e-mail address. Also, see my edit. – Chris S May 4 '12 at 15:32
I had provided the Exchange Alias, which happened to be the username (as is typical in my organization). I also used those permissions as shown in the edit above, and I changed the share path to \\localhost\EXPORT_PST rather than \\localhost\C$\EXPORT_PST just in case the administrative share was inaccessible to the trusted subsystem. – tacos_tacos_tacos May 4 '12 at 15:43
I've found the problem... in SP2, it does not warn you when you have not assigned your user to the correct management role group. As a result, it looks like it's a file permissions issue, but really it's a role management issue. After adding the appropriate user to the group with mailbox import export abilities and restarting PS, it works! Please update answer if possible so other newbies can see this. – tacos_tacos_tacos May 4 '12 at 16:02

There's builtin functionality in Exchange, which is different depending on whether or not you have SP1 or later installed.

For Exchange 2010 RTM, you'll have to install Outlook 2010 on the mailserver and change some permissions. There's a good walkthrough here.

Starting in Exchange 2010 SP1, you don't need Outlook installed - you can use the New-MailboxExportRequest command in PS. There's a description of how that works here.

share|improve this answer

Yes this is the Exact solution in my case...

The role group creation and Exchange Trusted Sub System Permission assignment everythings is done. But again I got the same error.

Even the MS KB is not given the solution for the same, they mention like it was a permission issues.

Finally the Powershell restart (close and Reopen) is the important task to get this done.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.