Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

One of our dev servers has a simple Apache setup for hosting URLs/documents that our analysts and cutomer service people can use to view reports, etc.

All of the sudden the URL they go to on this server is throwing back a 403 (forbidden) without accessing for auth.

I looked in httpd.conf and see the DocumentRoot set correctly:

DocumentRoot "/usr/local/apache/htdocs"

Looked at file timestamps and nothing has changed since September of last year. Anybody have any clue as to what could be going on here?

share|improve this question
Have you looked at ALL the unix permissions, including the parent directories, down to whatever the file is? – cjc May 4 '12 at 15:16
There will probably be more useful information in the Apache error log. If you see (13) after a permission denied error, it's a filesystem permission error, if not it's an Apache config permission error (such as Deny from x.x.x.x) – Ladadadada May 4 '12 at 15:36

Sudden/inexplicable 403 errors in Apache can be caused by changes/updates to selinux, if you're on CentOS/Redhat or some other selinux-using distro. (If not, which distro are you using? Put in it your question.) Check /var/log/audit/auditlog to see if that's the issue.

If it is the issue, you may choose to:

  • Relabel files in /usr/local/apache/htdocs
  • Change the selinux rules to prevent the error from occurring
  • Change selinux mode to "permissive" or disable selinux

More info:

share|improve this answer
Thanks @Nada - yes this is CentOS (good call!) In the audit log what would I be looking for to indicate changes/updates to selinux? – Mara May 4 '12 at 20:20
Hi @Adam - in the audit log you're looking for evidence that selinux is interfering with Apache, not evidence that selinux was updated. (Look in the yum log for evidence that selinux was updated.) Sorry for the delay in responding to you - I didn't see your comment. – Nada May 8 '12 at 16:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.