Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We are working with ProFTPd and SFTP module enabled. We have a problem with using the sftp module.

When we try to connect to server in FileZilla we need to enter the password to the server twice, upon connection and upon each file upload, which is very undesired. How can we help this? any idea's? suggestions?

when we use the interactive login type in FileZilla, it works when we enter the username and password twice.

share|improve this question
    
Have you tried any other clients besides FileZilla? – Andrew M. May 5 '12 at 12:25

If you're experiencing the same issue as I am you will find in your server's auth log that proftpd first tries pam_unix before falling back to the configured authentication method. For me I am using authuserfile and not Unix authentication. As with you my first attempts always fail and the second attempts always succeed.

The proftpd documentation would have you believe that AuthPAM off disables pam authentication entirely. I find this to be inaccurate as proftpd continues to try pam even with AuthPAM off and PersistendPassed off.

I recompiled proftpd without pam and now I can login the first time. The problem is that most distributions ship binary packages and may not even give you this ability. If that is the case then you could always modify pam to use the authentication method you require.

share|improve this answer
1  
If you are using the mod_sftp module, then the PAM support is a little different; it's via the mod_sftp_pam module. This, in turns, means that to disable PAM usage for SFTP logins, you would use SFTPPAMEngine off in the mod_sftp config. I agree, though, that this is confusing, and that having mod_sftp_pam pay attention to the AuthPAM directive would help. – TJ Saunders Jan 22 at 4:24
1  
This has now been changed/fixed in proftpd. – TJ Saunders Jan 22 at 4:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.