Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to run the passenger-install-apache2-module so I can install Redmine on CentOS 5.8, but passenger-install-apache2-module tells me I need Curl development headers with SSL support, which it tells me I can install using yum install curl-devel, however, when I run that I get the following results:

Loaded plugins: fastestmirror, priorities, protectbase
Loading mirror speeds from cached hostfile
 * base: ftp.pbone.net
 * extras: ftp.pbone.net
 * remi: remi-mirror.dedipower.com
 * updates: ftp.pbone.net
120 packages excluded due to repository priority protections
0 packages excluded due to repository protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package curl-devel.i386 0:7.15.5-15.el5 set to be updated
--> Processing Dependency: curl = 7.15.5-15.el5 for package: curl-devel
--> Finished Dependency Resolution
curl-devel-7.15.5-15.el5.i386 from base has depsolving problems
  --> Missing Dependency: curl = 7.15.5-15.el5 is needed by package curl-devel-7.15.5-15.el5.i386 (base)
Error: Missing Dependency: curl = 7.15.5-15.el5 is needed by package curl-devel-7.15.5-15.el5.i386 (base)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Now I'm not amazing with linux stuff, however, I think this tells me that I need version curl if I want to install curl-devel (makes sense). But I know I have curl install, and I do curl -V to test if it is actually install, and this gives me:

curl 7.21.7 (i686-redhat-linux-gnu) libcurl/7.21.7 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5 libssh2/1.2.7
Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtsp scp sftp smtp smtps telnet tftp
Features: AsynchDNS GSS-Negotiate IDN IPv6 Largefile NTLM SSL libz

So I think the problem is the difference in versions, however, I have no idea where to go from here.

So my question is, how do I install curl-devel properly?

BTW: I did try what yum told me to try at the end:

 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
share|improve this question

1 Answer 1

up vote 0 down vote accepted

You need the same version of curl-devel and curl. The package passenger-install-apache2-module require the version 7.15.5-15.el5 of curl-devel so you need to update curl to version 7.15.5-15.el5. You have installed a greater version of curl package, the version is 7.21.7.

Your server use as repository rpmbone, this repository contains curl version 7.15.5-15.el5. These are the packages url: ftp.centos.org/5.8/os/x86_64/CentOS/curl-7.15.5-15.el5.x86_64.rpm ftp.centos.org/5.8/os/i386/CentOS/curl-7.15.5-15.el5.i386.rpm

You can try to remove curl.7.21.7 if it isn't a dependency of other package and install curl and curl-devel 7.15.5-15 using the command "yum install curl-7.15.5-15 curl-devel--7.15.5-15"

share|improve this answer
    
Removed curl, but it can't find those packages, also I tried yum install curl curl-devel, but giving me the following error: Transaction Check Error: file /usr/lib/libcurl.so.3.0.0 from install of curl-7.15.5-15.el5.i386 conflicts with file from package compat-libcurl3-7.15.5-1.el5.remi.i386 –  Hosh Sadiq May 7 '12 at 21:37
    
Thanks I can now install Git because I made sure curl and curl-devel were the same version 1. yum remove curl 2. yum remove curl-devel 3. yum install curl-7.12.1 curl-7.12.1 4. yum install git –  user124242 Jun 11 '12 at 6:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.