Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to connect to my computer at work using my Mac at home. I have Microsoft Remote Desktop Connection application installed on my Mac, and I also have a working VPN connection to my SBS 2003 server at work. But somehow I'm unable to connect to my computer using it's Windows name like 'MyComputer1'. I'm also unable to connect to the fileserver using it's hostname. It works if I connect using it's IP.

Does anyone know if it's possible to configure the Mac client or the server so I can connect to the Windows computers with their Windows hostnames?

Best regards, --Andreas

share|improve this question
add comment

5 Answers

Really, this is probably something that has more to do with your VPN. If your VPN added/replaced the DNS servers used for resolution with the ones you have at work then connecting by name should work. If the names of these servers are available in a public DNS zone then perhaps all you would have to do is connect to the host with the fully qualified domain name i.e. servername.yourcompany.example.org.

share|improve this answer
    
I'm a bit uncertain about what I did, but now I'm able to connect to my computer and any other computer in my network as long as I use the fully qualified name eg: MyComputer1.MyDomain.local –  user11800 Jul 9 '09 at 22:24
add comment

RDC for Mac uses only DNS or IP address information, so trying to connect via the NetBIOS name will not work.

share|improve this answer
add comment

Try using the FQDN. Better still, use the IP address, which is what I do and I have not had a problem connecting.

share|improve this answer
add comment

It's a conflict between Bonjour and DNS (.local tld). Apple has a support article on it: http://support.apple.com/kb/HT3473

You probably got it to work by putting in yourdomain.local in the "Search Domains" field under the networking settings.

share|improve this answer
add comment

dns suffix would help. either you add it to your vpn settings or you just use fqdn to supplement what is not there. very common error both on macs and win clients.gd

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.