Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm migrating a webapp to a fresh server. We use awstats to process log analysis.

I've installed awstats and I have migrated the config files in /etc/awstats, I've also migrated the associated Apache 2 virtual host to access the stats.

I've tried to preserve old data by moving the files in /var/lib/awstats from the old to the new server.

But trying to access the awstats data fails:

Error: awstats can't read down more than 10 level of includes. Check that no 'included' config files include their parent config file (this cause infinite loop).

Setup ('/etc/awstats/awstats.stats.mydomain.com.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory). 

EDIT: I've checked rights on the data in /var/lib/awstats, I've assumed that the config files of the virtual host and in /etc/awstats are ok since they worked fine on the previous server (I've doublechecked them anyway).

share|improve this question
1  
Did you do what the error message suggests? "Check config file, permissions and AWStats documentation (in 'docs' directory)." –  Oliver May 5 '12 at 20:55
    
Yes, that's what I did (see edit), but this is quite vague. –  AsTeR May 5 '12 at 21:27

1 Answer 1

up vote 2 down vote accepted

I would check all the Include directives in the configuration file which fails and try to follow them manually. Maybe there is an additional file on the new server which was not on the old server.

share|improve this answer
    
Excellent, all my files called a file that was empty on the old server but contain unused code on the new one. Thanks a lot ! –  AsTeR May 5 '12 at 21:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.