Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a NAS mount, and I can copy file to this,
but I can't copy files similar to this

cp /home2/user/WRF/WRFV3/run/*_2 . -v
`/home2/user/WRF/WRFV3/run/wrfout_d04_2007-11-21_00:00:00_2' -> `./wrfout_d04_2007-11-21_00:00:00_2'
cp: cannot create regular file `./wrfout_d04_2007-11-21_00:00:00_2': Not a directory

I get this error.

EDIT

when I try make a file with : in the name, I get a error

$ date >> file\:file
-bash: file:file: Not a directory

but this command work in my home

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

If your NAS server is running samba/smb/cifs then it may object to colons (:) in file names (subject to mapchars being set).

share|improve this answer
add comment

You receive the error when you try to copy a symbolic link.

Do you want copy also the symbolic link?

If the answer is yes use the flag "-d"

-d, --no-dereference Copy symbolic links as symbolic links rather than copying the files that they point to, and preserve hard link relationships between source files in the copies.

share|improve this answer
    
the files are regular files, in the directory not exist a symbolic link –  JuanPablo May 7 '12 at 16:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.