Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

WHen i enable suphp and disable php5 i get an internal server error, and these two in my error log. I have tried for ages to figure it out however it still will not work. It originally used to work but after an update it broke.

Premature end of script headers: index.php, referer: mywebsite.com

 SecurityException in Application.cpp:511: Unknown Interpreter: php

EDIT Now suphp works on one of my virtual hosts and not the other. I get the error

Mon May 07 21:43:07 2012] [error] [client ip] *** stack smashing detected ***: /usr/bin/php-cgi terminated
[Mon May 07 21:43:07 2012] [error] [client ip] Premature end of script headers: index.php
[Mon May 07 21:43:15 2012] [error] [client ip] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525/suhosin.so' - /usr/lib/php5/20100525/suhosin.so: cannot open shared object file: No such file or directory in Unknown on line 0

suPHP Conf

root@localhost:/etc/apache2/sites-enabled# cat /etc/suphp/suphp.conf
[global]
;Path to logfile
logfile=/var/log/suphp/suphp.log

;Loglevel
loglevel=info

;User Apache is running as
webserver_user=www-data

;Path all scripts have to be in
docroot=/${HOME}/public_html

;Path to chroot() to before executing script
;chroot=/mychroot

; Security options
allow_file_group_writeable=false
allow_file_others_writeable=false
allow_directory_group_writeable=false
allow_directory_others_writeable=false

;Check wheter script is within DOCUMENT_ROOT
check_vhost_docroot=true

;Send minor error messages to browser
errors_to_browser=false

;PATH environment variable
env_path=/bin:/usr/bin

;Umask to set, specify in octal notation
umask=0077

; Minimum UID
min_uid=100

; Minimum GID
min_gid=100


[handlers]
;Handler for php-scripts
x-httpd-php="php:/usr/bin/php-cgi"

;Handler for CGI-scripts
x-suphp-cgi="execute:!self"

I get these errors on my wordpress installation.

EDIT The error has reoccurred on another VHOST

share|improve this question
    
Post your suphp.conf and the relevant lines of your webserver configuration if you want anybody to help you. –  Oliver May 7 '12 at 19:46
    
Added suphp, which web configs do you want? –  h00j May 7 '12 at 19:49
    
What do the two vhosts have in common, what differs? Do you have two different php.ini files? Also, know that suPHP is very picky about permissions. Did you check suphp.log, or only your webserver error.log? –  Oliver May 7 '12 at 20:03
    
The suphp log shows nothing interesting, no errors. I just checked, normal .html files also work on the same domain that i get the internal server error. I only seem to get the internal server error on the wordpress files –  h00j May 7 '12 at 20:11
    
Since you have loglevel set to info and see nothing interesting, are you really sure you are indeed using suphp on the vhost which causes trouble? Do you see anything at all related to your request which causes the internal error? –  Oliver May 7 '12 at 20:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.