Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In my network configuration, I have three switches:

  1. Internet (xx.xx.140.129/25)
  2. Internal SAN (10.1.1.0/24)
  3. iLo management (10.1.30.0/24)

I have one Linux server which I use for management that needs to have access to all three networks, however it only has 2 NICs. I've cabled switches #2 and #3 together, so there is a physical path between them, and I've tried ip route add 10.1.1.0/24 eth0, but that did not work. Any ideas on how this could be done?

[root@ilo]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
XX.XX.140.128 0.0.0.0           255.255.255.128 U     0      0        0 eth1
10.1.30.0       0.0.0.0         255.255.255.0   U     0      0        0 eth0
10.1.1.0        0.0.0.0         255.255.255.0   U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth1
0.0.0.0         XX.XX.140.129   0.0.0.0         UG    0      0        0 eth1
share|improve this question
    
What did not work in your config? Which network tests are failing? –  Mircea Vutcovici May 7 '12 at 20:30
    
please show output from ifconfig –  Peter May 8 '12 at 12:11
    
or "ip addr" if you prefer (to be consistent since you are using "ip ..." for the rest) –  Peter May 8 '12 at 12:14

2 Answers 2

If you want to separate the traffic for security reasons, you should use VLAN tagging. For this you will need managed switches.

If you do not need to separate the traffic for security, then you should use the same IP prefix for #2 and #3

If you still want to use your design, (e.g. if you plan to separate the networks later with managed switches), then you can use IP aliases (add secondary IP addresses) on an interface.

To debug your network problem go on the network stack from physical layer to the application one:

  1. test your cables. Do you have link up on all interfaces on the path? e.g. all ethernet LEDs are blinking for all interfaces?
  2. is the device answering to arping, ping. Try both using IP and hostname.
  3. run traceroute and see how the packets are routed. Debug with ip route get <IP_destination> to find on which interface will the packets get routed.
  4. use telnet, nc, etc. to see if the application is answering.

EDIT: Run:

ip route del 10.1.1.0/24 dev eth0   # remove the fixed route
ip addr add 10.1.1.1/24 dev eth0    # add an IP alias 

The problem is that you do not have an IP from 10.1.30.0/24 prefix on the eth0.

share|improve this answer
    
<pre>tracert 10.1.1.40 traceroute to 10.1.1.40 (10.1.1.40), 30 hops max, 40 byte packets 1 10.1.30.10 (10.1.30.10) 3000.008 ms !H 3000.010 ms !H 3000.006 ms !H –  John P May 8 '12 at 2:32
    
arping 10.1.1.40 ARPING 10.1.1.40 from 10.1.30.10 eth0 Sent 49 probes (49 broadcast(s)) Received 0 response(s) –  John P May 8 '12 at 2:32
    
arping works only if the 2 devices are in the same VLAN. –  Mircea Vutcovici May 8 '12 at 2:38
    
Is it working with ip addr add ... ? –  Mircea Vutcovici May 8 '12 at 17:47

Setting the route is only part of the game, but how does the internal SAN network know how to get to your 10.1.30.10? It's missing it's route back.

Simplest solution: assign an IP of subnet 10.1.1.0/24 to your eth0:

ip addr add 10.1.1.xyz/24 dev eth0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.