Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In IIS (Windows Server 2008) I open the IIS Manager, then expand the local server name, the expand "Sites" and right click on "Default Web Site" but no "Properties" show up.

According to this Microsoft article, that is where I would go to find the logging options (which I need to turn on).

What am I missing? I can stop or start "Default Web Site" no problem. The right click menu only brings up:

  • Explore
  • Edit Permissions
  • Add Application
  • Add Virtual Directory
  • Edit Bindings
  • Manage Web Site -> Restart/Start/Stop/Browser, Advanced Settings (no Logging tab)
  • Refresh
  • Remove
  • Rename
  • Switch to Content View

Under the Features View, I don't see Logging either. I see:

  • .NET Auth
  • .NET Compilation
  • .NET Error Pages
  • .NET Globalization
  • .NET Trust Levels
  • Application Settings
  • Connection Strings
  • SMTP E-mail
  • Authentication
  • Handler Mappings
  • HTTP Responses
  • Modules
  • Output Caching
  • Request Filtering
  • SSL Settings
  • Configuration Editor
share|improve this question

2 Answers 2

up vote 5 down vote accepted

It sounds as if you've not installed any of the logging elements of the Health and Diagnostics IIS Role Service:

enter image description here

You need to install at least the "HTTP Logging" role service for the Logging feature to appear.

share|improve this answer

That context menu you list is clearly not IIS6, but IIS 7.0.

When you choose a web site in the left pane, the "Feature View" should open in the middle pane, here is a feature option called "Logging", denoted by a notepad-like icon.

Depending on whether you need to configure the "default" logging settings (on server-level) or logging for a specific site, read one of the articles listed here: http://technet.microsoft.com/en-us/library/cc732079(v=ws.10).aspx

share|improve this answer
    
My bad, I read "Version 6.1" under Help-About in IIS but that appears to represent the OS? –  JBurace May 7 '12 at 22:21
    
I checked the Feature View and see no Logging. See my question for the edit. –  JBurace May 7 '12 at 22:24
1  
Check the Web Server Role in Server Manager on the machine, and make sure that the logging feature is installed –  Mathias R. Jessen May 7 '12 at 22:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.