Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having problems with my server. The server info is below. The problem I'm having it just started a few days ago after a server restart. I use in my php code

@get_headers($url);

I'm also using Google recaptcha. The problem I'm having is when my server outbound connections run real slow. I don't timeout it just takes about 10 seconds to get a header request or to connect to google recaptcha. I tried pinging out of the machine it works but each ping takes for ever not to ping but to start. I checked the name servers and there fine and there the same on my other two servers that are under the same network. My question is where do I start or what commands do I need to enter to trouble shoot this.

Thank you

Server Info:

Ubuntu Linux 11.10
Apache/2.2.20 (Ubuntu)
PHP 5.3.6-13ubuntu3.7 
Kernel and CPU: Linux 3.0.0-19-server on x86_64
share|improve this question
    
Please add more detail surrounding "I checked the name servers and there fine" –  wfaulk May 7 '12 at 23:39
    
@wfaulk In my etc/resolv.conf folder there the same nameservers as my other two boxes and there fine and there under the same network. –  Tabatha M May 7 '12 at 23:49
    
I was hoping for the results from a dig or equivalent. Also, "they're", not "there". –  wfaulk May 7 '12 at 23:57
    
For some reason it's working now. Also I understand my grammar is bad you understand me though. It's hard I didn't really finish school. I got my G.E.D. What can I say though bad grammar being 25 and retired since I got lucky on the internet. Sorry man –  Tabatha M May 8 '12 at 0:07

1 Answer 1

up vote 1 down vote accepted

I've seen this happen when reverese DNS lookups time out. You might want to check that the *.in-addr.arpa. zones are properly configured for your DNS servers.

You may also want to test just doing a simple reverse lookup of the connecting hosts from the servers, e.g. host 192.168.1.1 if you have a client "192.168.1.1" attempting to connect

It could help to make sure reverse lookups are turned off in apache via httpd.conf:

HostnameLookups Off
share|improve this answer
    
I checked apache2.conf and "HostnameLookups Off" is off already. I only use A records and vhost. The name servers are configured just like the other two boxes. They do not have a problem. I will try to see how to check "*.in-addr.arpa." zones. Thank you –  Tabatha M May 7 '12 at 23:44
    
Could it be something to do with dns caching? Are you running nscd on all three servers? –  zje May 7 '12 at 23:48
    
I'm not using "nscd" just checked. –  Tabatha M May 7 '12 at 23:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.