Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i work with unix server 11.31. Now i want to move my binaries to unix 11.11. I am confused will those binaries will work in 11.11 since there was some signal changes and configuration changes in newer version.

share|improve this question
2  
I assume you talk about HP-UX? And why do you want to migrate to an 12 year old OS (11.11) from a five year old (11.31)? –  Sven May 8 '12 at 7:23
    
Since my production server is in earlier version i need to move my binaries –  sooraj May 8 '12 at 9:50

1 Answer 1

up vote 1 down vote accepted

Binary compatibility is only usually guaranteed on forward versions (i.e. binaries compiled on version xx.1 will run on xx.2). I do not specifically know how HP handles this for HP-UX, but I would expect it not to guarantee backward binary compatibility.

You would be safer off re-compiling your code against the previous version.

Or, you could move the binaries and see if they run - might be quickest.

More info on some HP-UX binary compatibility stuff here.

share|improve this answer
    
But my binaries working in 11.11 were not working in 11.31...i need to do certain changes. Hence am confused due to these changes will it work in 11.11 –  sooraj May 8 '12 at 9:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.