Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm exploring daemontools to run some of our applications, which generate some output as well (on both stdout and stderr).

I installed daemontools on a debian box. Every time, I do a svc -u /etc/service/myservice to start the service, I get a [defunct] process. How can I go about debugging this problem.

Following is my /etc/service/myservice/run:

exec myservice -c /etc/myservice/myservice.conf

and /etc/service/myservice/log/run

exec multilog t ./main

Any help would be apppreciated. Thanks.

share|improve this question
More information are velcome. For example, what happens when you directly run /etc/service/myservice/run ? – Gregory MOUSSAT May 8 '12 at 13:31
It runs just fine, spewing out messages on the console (both stderr and stdout). – Lazylabs May 8 '12 at 17:30
So try to run it with the same user as daemontools will use for it. This can also be a problem of environement: what happen if you run it from cron ? – Gregory MOUSSAT May 9 '12 at 0:01
up vote 2 down vote accepted

You can catch some errors with ps -aux | grep readproctitle.

Some debugging ideas:

  • myserver is not in the PATH. Consider specifying the full path to the program.
  • myserver forks into background: This is explicitly forbidden with services started using daemontools.
  • Permissions: Double-check the permissions of the directories and of the run script.
share|improve this answer

I faced the same issue. When nothing else worked, this worked for me :

  • Find the pid of svscanboot through ps auxf. You will see that it starts svscan which monitors all the services.
  • kill -9 -pid.

svscanboot will start automatically and so will all services under svscan.

I faced the issue when named pipe of svcan gets corrupt when no disk space is left on machine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.