Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

A "client" system and a "server" system are connected via crossover cable. The "client" is running Windows Server 2003, and the "server" is running Windows XP Pro SP3.

The client and server ping fine both ways. When I try accessing file shares (i.e.: C$) on the client system, using the server, it works fine. My problem is that when I use the client to access files on the server, I get a "no logon servers available" error.

I'm logged on to each system using local accounts. This error generally occurs without prompting me for any credentials, but also will happen after credentials have been provided.

I've Googled this thing to death, and nothing's worked so far. What's most baffling is that it's happening at all, when I'm trying to use local accounts to connect. What could I be missing here?

share|improve this question
    
Are you connecting via IP or via hostname? Also, if you have GbE cards on both ends, you don't need a crossover cable. –  MDMarra May 8 '12 at 17:08
    
@MDMarra Using IP address or hostname, it behaves the same. And, I am actually using a straight cable. I just wanted to make it fully clear that it's a direct PC-to-PC connection. –  Iszi May 8 '12 at 17:17
    
Is either system a domain member? –  wfaulk May 8 '12 at 17:26
    
@wfaulk Both systems are members of a domain - whether it's the same domain or not, at this point, I'm not sure yet. Again, though, we are operating offline from the domain and trying to use local accounts to authenticate. –  Iszi May 8 '12 at 17:30
1  
Just FYI to future answers: "Computer Configuration -> Policies -> Windows Settings -> Security Settings -> Local Policies -> Security Options -> Interactive Logon: Require Domain Controller authentication to unlock" is disabled for these machines –  Joel E Salas May 8 '12 at 18:56
show 10 more comments

2 Answers

If you need to see the configuration of the server, do that using WMI. Checking individual files on a running system via CIFS is Not Correct.

Unfortunately, we don't always have access to the correct way. If the tool you're using needs access to the filesystem, you can share the filesystem in other ways, including NFS, SFTP, etc.

share|improve this answer
    
This is not an option. The tool we use is not one which we can alter in a way that would circumvent this problem. And, it is required that we use this specific tool. –  Iszi May 8 '12 at 19:07
add comment

We ended up resolving the issue by removing the server from the defunct domain. Once it was in "workgroup" configuration, the shared folders behaved normally.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.