Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a CentOS 5.X with Kloxo panel.

It's a test enviroment but i have 2 pages there.

I noticed theres 113 packets to be update (php, kloxo, wget, openssl, and a long etc)

But when i do the command

yum update

I get a conflig with /etc/my.cnf file.

This is the message

Transaction Check Error:

file /etc/my.cnf from install of mysql-5.0.95-1.el5_7.1.i386 conflicts with file from package mysql-libs-5.0.92-lxcenter.1.i386

file /usr/lib/mysql/libmysqlclient.so.15.0.0 from install of mysql-5.0.95-1.el5_7.1.i386 conflicts with file from package mysql-libs-5.0.92-lxcenter.1.i386

file /usr/lib/mysql/libmysqlclient_r.so.15.0.0 from install of mysql-5.0.95-1.el5_7.1.i386 conflicts with file from package mysql-libs-5.0.92-lxcenter.1.i386

The problem is, i dont really know what is happening here.

For me, there is 2 installs of mysql.

One is from lxcenter (kloxo) an the other one maybe was there from the beginin?

If it's that, how i can uninstall the second one and don't touch the kloxo mysql?

Thanks a lot!

share|improve this question

1 Answer 1

up vote 0 down vote accepted

If you want to uninstall the original one you have to find out the name of the package and be careful when uninstalling it. You will find out name of the packages by running:

rpm -qa|grep mysql

then once you are sure you found the right package to remove you'd have to run:

rpm -e <package_name>

You might have to run it with --no-deps option so that it doesn't mess other things up - also you might want to try the --test option which is basically dry-run and see whether everything will go fine. It looks like the kloxo mysql libs are conflicting with the ones which are already in place on the server.

share|improve this answer
    
there are 4 packages. mysql-libs-5.0.92-lxcenter.1 mysql-5.0.92-lxcenter.1 mysql-server-5.0.92-lxcenter.1 php-mysql-5.2.17-1 i'm prety sure is the last one. but the php-mysql anoins me, that have something to do with php install? –  nax May 9 '12 at 9:06
    
but if i see the error again it sais: mysql-5.0.95-1.el5_7.1.i386 conflicts with mysql-libs-5.0.92-lxcenter.1.i386 so the package name is the first one right? why is'nt listed? :( –  nax May 9 '12 at 9:09
    
if the package wasn't installed via rpm/yum but rather was compiled from source then you won't see it in rpm -qa output - otherwise you should and must see it there. But from what I can see is that you must remove the following package: mysql-5.0.95-1.el5_7.1.i386, you should just run sudo rpm --nodeps --test -e mysql-5.0.95-1.el5_7.1.i386 and see if that goes OK, if yes then remove the "--test" bit and run it normally. That will remove the conflicting package –  gyre May 9 '12 at 12:58
    
i gonna try tomorrow and i tell something ;) thanks –  nax May 10 '12 at 17:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.