Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to get pacemaker to retry starting my resource

primitive Imq ocf:example:imq \
   op monitor on-fail="restart" interval="10s" \
   op start interval="0" timeout="60s" on-fail="restart" \
   meta failure-timeout="30s"

Note that this resource is pinned to the first node via

location location_Imq Imq inf: vm1
location location_Imq1 Imq -inf: vm2

Currently if I break something that stops this resource from starting the failure count returns INFINITY and stops attempting to restart the service.

I would like to never give up on the resource so that once the intermittent issue clears its self the resource restarts and resumes service.

Using pacemaker 1.0 on CentOS.

share|improve this question
up vote 5 down vote accepted

It turns out the solution is quite simple all that is needed is to set 'start-failure-is-fatal' to false.

crm configure property start-failure-is-fatal=false

This is a global option and it's default is true hence my failing resource.

Pacemaker configuration reference

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.