Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was able to SSH into my VPS earlier today, and made no major changes. However now when I attempt to SSH into my VPS it doesn't even ask me for my password it just times out.

If I open the serial console and attempt to SSH via localhost it works fine. I have also pinged my hostname and ip address and both of these show the server is up.

Does anyone know what could be causing this?

share|improve this question
Is your sshd running? – Bart De Vos May 9 '12 at 18:15
Sounds like either a FW issue or the SSH/OpenSSH service is down, is the process running? – Chopper3 May 9 '12 at 18:15
@BartDeVos ps -A | grep ssh returns 3748 ? 00:00:00 sshd 17478 pts/0 00:00:00 ssh 17479 ? 00:00:00 sshd 17481 ? 00:00:00 sshd Honestly I have no idea what this means (am a newbie) – George Reith May 9 '12 at 18:16
@BartDeVos I also restarted sshd to be safe still nothing – George Reith May 9 '12 at 18:21
@Chopper3 What is FW? – George Reith May 9 '12 at 18:21
up vote 4 down vote accepted

Things to check:

  1. Check your route; on your client run traceroute <ip>
  2. Check your name resolution; on your client and server run dig <hostname>
  3. Check your firewall; on your server run iptables --list (test ssh with your client firewall disabled as well)
  4. Restart the service; /etc/init.d/sshd restart (or whatever is appropriate for your distro)

Beyond those issues there could be a few more, including errors or outages at the VPS provider.

share|improve this answer
Ok all of those are checking out ok (still no SSH) apart from I am unable to run iptables --list it doesn't understand that command. – George Reith May 9 '12 at 19:10
run which iptables, you might need to run sudo iptables --list – Joseph Kern May 9 '12 at 19:15
which iptables returns /usr/bin/which: no iptables in (/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin) and sudo iptables ---list returns sudo: iptables: command not found – George Reith May 9 '12 at 19:21
Did you turn off your client-side firewall? (strange that you don't have iptables installed, which distro is this?) – Joseph Kern May 9 '12 at 19:26
CentOS 5.5 32bit, I installed centmin mod – George Reith May 9 '12 at 19:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.