Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Using windows RDP, I'm trying to connect to a remote machine to which I connected fine moments earlier. I had to reboot the server...

Now, I type in my credentials and it looks like its working (the status text rapidly changes).

"Connecting to remote server" "Configuring remote session"

then it does nothing and returns to the main connection window. No error message. Just does nothing.

I can connect to other machines fine. If I enter a wrong password, it rejects me.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

The credientials are stored as the connection is being built. So even though it asks, doesn't mean it is connected when doing so. Verify that RDP is running on that machine and that the Firewall isn't interfering with your connection. Also, check the event logs to see if possibly the service crashed for some reason. My first vote would be the connection is being blocked by the windows firewall.

share|improve this answer
So even though it asks, doesn't mean it is connected when doing so. Well, it rejects bad usernames, so I know that the network service is trying to verify credentials on the remote machine, and if it got that far, it's not a firewall. Plus the firewall is all hardware and there's no reason that would change between reboots. – FlavorScape Jul 6 '12 at 19:24
Agreed. If you are getting a message complaining about invalid credentials, then you are getting the point of talking to the server. Have you tried restarting terminal services (Remote Desktop Services for non servers) on the machine in question? Maybe the service is corrupted or is crashing and the service is stopping. – MikeAWood Jul 10 '12 at 5:56
This only happens when the remote machine is rebooted via remote desktop. Consistent. RDP works fine to another machine. – FlavorScape Aug 10 '12 at 22:42

I've encountered this type of behavior several times so far with Windows 8/8.1 or Server 2012 machines when they've been rebooted and have a lot of updates to install. For whatever reason it appears that the RDP password prompt will appear if you try to connect while it is still installing updates even though you can't actually connect. In those cases it has resolved once the updates have finished installing, but depending on the number and type of updates it can take quite a while because sometimes it will reboot several times during the install process.

Could be completely unrelated to your problem especially since your question was asked before Windows 8 was RTM, but I thought I'd add this reference for additional info. It's happened enough times to me in completely different environments that I don't see it just being a random quirk.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.