Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a site running on my home server that's just a front end for me to grab files remotely. There's no pages, just a directory listing (Options Indexes...). I wanted to add a link to a directory outside of the webroot so I made an alias. After a minute of dealing with permissions, I can now navigate to the directory by typing the URL into the browser, but the directory isn't listed in the root index. Is there a way to do this without creating a symlink in the root?

Server: Ubuntu 11.04, Apache 2.2.19

Relevant vhost:

<VirtualHost *:80>
  ServerName some.url.net

  DocumentRoot "/var/www/some.url.net"
  <Directory /var/www/some.url.net>
    Options Indexes FollowSymLinks
    AllowOverride None
    Order Allow,Deny
    Allow From All

    AuthType Basic
    AuthName "TPS Reports"
    AuthUserFile /usr/local/apache2/passwd/some.url.net
    Require user user1 user2
  </Directory>

  Alias /some_alias "/media/usb_drive/extra files"
  <Directory "/media/usb_drive/extra files">
    Options Indexes FollowSymLinks
    Order Allow,Deny
    Allow From All
  </Directory>
</VirtualHost>
share|improve this question

2 Answers 2

up vote 0 down vote accepted

No. Aliases never show up as part of the filesystem; they only exist in the web server, and mod_autoindex only deals with the filesystem.

share|improve this answer
    
Thanks for the info. I guess the directory will just be my little secret. –  Phunt May 10 '12 at 3:47

Yes, you can use Options Indexes MultiViews

  Alias /some_alias "/media/usb_drive/extra files"
  <Directory "/media/usb_drive/extra files">
    Options Indexes MultiViews
    Order Allow,Deny
    Allow From All
  </Directory>

Hmm, the wrong answer is accepted. And the correct answer is edited?

Maybe it's only strange to me, since I have Vietnamese culture ;-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.