Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm upgrading our network from Exchange 2003 to Exchange 2010 and it's going swimmingly. Well it was, I've moved some users to the 2010 box with blackberries (iphones working fine) and I can't get it working with BIS (blackberry internet services)

Whatever settings I try I get a

An error occurred during email account validation. Please check your information and try again. If the error persists please contact your System Administrator.

error.

I'm using http://mail.mydomain.com/owa url, which works fine and the authentication settings I'm trying (username / password) work fine in owa.

Close to the point of pulling my hair out on this issue, is there a way to find out what it's failing on? Have I missed something very simple?

Tom

share|improve this question
    
Are you using the https:// secure URL? –  ewwhite May 10 '12 at 10:24
    
I'm not no. Do I have to? –  Tom Beech May 10 '12 at 10:28
    
I typically do, but I also have redirects in place. Try the suggestions below. –  ewwhite May 10 '12 at 10:30
add comment

2 Answers 2

Did you try the http and https URLs?

Also see if you can see the Exchange Web Services directory:

(input a username/password)

`http://mail.maildomain.com/EWS/Exchange.asmx`
`https://mail.maildomain.com/EWS/Exchange.asmx`

You should get an XML page after successful authentication.

share|improve this answer
    
I've tried now with and without and it works (in owa) and EWS works fine, but EWS isnt the link that goes in BIS settings yeah? –  Tom Beech May 10 '12 at 10:30
    
No, that's not the link you'd use. Just a validation of your EWS directory accessibility. Did you try this without the "owa" portion of the URL? –  ewwhite May 10 '12 at 10:34
    
Yeah I have. It's so frustrating it's unreal! Did you have to change anything in exchange? –  Tom Beech May 10 '12 at 10:40
add comment

With 2010, from my experience, it has to be https://mail.mydomain.com/owa

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.