Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a FreeBSD server with root access and I'm trying to install java on it. I've tried to install diablo from the /usr/ports/java/diablo-jre15 directory, and it gave me a URL to download a file to /usr/ports/distfiles/. I did what it said, and then I ran:

make install clean

and it gave me the following error:

===>  Vulnerability check disabled, database not found
===>  Found saved configuration for diablo-jre-1.5.0.07.01_9
===>  Extracting for diablo-jre-1.5.0.07.01_9
=> MD5 Checksum mismatch for diablo-latte-freebsd6-i386-1.5.0_07-b01.tar.bz2.
=> SHA256 Checksum mismatch for diablo-latte-freebsd6-i386-1.5.0_07-b01.tar.bz2.
===>  Refetch for 1 more times files: diablo-latte-freebsd6-i386-1.5.0_07-b01.tar.bz2 diablo-latte-freebsd6-i386-1.5.0_07-b01.tar.bz2
===>  Vulnerability check disabled, database not found
===>  Found saved configuration for diablo-jre-1.5.0.07.01_9
=> diablo-latte-freebsd6-i386-1.5.0_07-b01.tar.bz2 doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch from ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/.
fetch: transfer timed out
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles/ and try again.
*** Error code 1

I can see that the file is in the right directory and still it gives me the same error.

I'm using FreeBSD 6.2-RELEASE-p12.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

Diablo JDK/DRE is horribly outdated. Don't use it.

Install java/openjdk6 instead (or java/openjdk7 if you want the devel version)

If these do not appear in your ports tree (as you're using a similarly horribly outdated, unsupported version of FreeBSD with known security vulnerabilities) you'll need to update it with cvsup, csup, or portsnap (not sure if it that was available in 6.2).

share|improve this answer
    
ok, i've run the make install clean in the /usr/ports/cvsup.. what's next ? –  Asaf Nevo May 10 '12 at 16:05
    
i had an error in the cvsup installation.. can i download an installation of openjdk6 ? –  Asaf Nevo May 10 '12 at 16:38
    
If you're installing cvsup for the command line you'll want usr/ports/net/cvsup-without-gui; you can grab a package of the oJDK6 for the 6-Stable branch from ftp-archive.freebsd.org/pub/FreeBSD-Archive/ports/i386/… <-- Note that's in the archives now... You can't automatically install packages with the pkg_add -r $PKG_NAME command anymore. Is upgrading to a newer version of FreeBSD an option at all? –  Chris S May 10 '12 at 17:07
    
nope, not for now.. this is a shared server... –  Asaf Nevo May 10 '12 at 17:23
    
i've used wget to download it, what now ? sorry its the first time i'm using freebsd (or linux) and i only know basic commands.. –  Asaf Nevo May 10 '12 at 17:25
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.