Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a HP Procurve with the following:

vlan 4 
  name "Phones" 
  untagged 20 
  ip address 10.50.60.1 255.255.252.0 
  qos dscp 101110 

qos device-priority 10.50.100.10 dscp 101110 
qos device-priority 10.50.20.38 dscp 100010 
qos type-of-service diff-services 

What is the Cisco equivalent command to accomplish the same?

Thanks

share|improve this question
2  
You have 0% accept rate on your questions. I suggest you accept some answers on your questions. Other SF users are then more motivated to answer your future questions. (accepting can be done by pressing the V next to the answer). –  Lucas Kauffman May 10 '12 at 23:10

1 Answer 1

Assuming port GigabitEthernet1/20 in the Cisco switch...

You need to define the vlan interface on the Cisco...

interface Vlan4
 description Phones
 ip address 10.50.60.1 255.255.252.0

Then assign a switch port to the vlan...

interface GigabitEthernet1/20
 switchport access vlan 4
 switchport mode access
 auto qos voip trust 
 spanning-tree portfast
 spanning-tree bpduguard enable

As far as defining maps for your QoS policy, it may be dependent on the model of your Cisco switch.
You'll want dscp mode 46 for IP 10.50.100.10 (ef) and dscp mode 34 for IP 10.50.20.38 (af41).

My setups look like:

policy-map AutoQos-VoIP-Output-Policy
 class AutoQos-VoIP-Bearer-QosGroup
   set dscp ef
   set cos 5
    priority
    police cir percent 33

and on the port level...

 service-policy input AutoQos-VoIP-Input-Cos-Policy
 service-policy output AutoQos-VoIP-Output-Policy

What type of switch are you using?

share|improve this answer
    
I'm using a Cisco 3560G-48TS –  Magd May 10 '12 at 23:26
    
How do I add the dscp mode for the IP addresses? –  Magd May 10 '12 at 23:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.