Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Apache 2.2 Server up and running my Website on my Windows 2003 Server. I now want to give visitors the ability to upload/download data to my site. So, I installed Apache FTPServer 1.6 but the last line of the installation said that the fTPD failed to install.

Finally after repeated attempts, the FTPD installed with no errors.

I then tried to "start" the program, but it won't start the service. I get the message "Windows could not start the Apache FTPServer on local computer."

I have tried starting the program numerous times, but with no success. I don't have any ports open that are competing with the port that FTP wants to use. Nor, do I have a firewall in the way. Any ideas that I could try?

share|improve this question

migrated from webmasters.stackexchange.com May 11 '12 at 9:47

This question came from our site for pro webmasters.

    
It seems to me that the service is failing to start because it was not installed completely (as the first part of your question states). I would recommend you try reinstalling the application and, barring that, find a different FTP server solution. –  Justin Pearce May 11 '12 at 3:27
    
I'm sorry Justin, but I wasn't clear in my first paragraph. –  John Wesley May 11 '12 at 7:55

1 Answer 1

I suggest you configure logging: http://mina.apache.org/ftpserver/logging.html (log4j), and then look at the log on why startup fails

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.