Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After a brand-new install of Ubuntu 9.04 Desktop or Server into a VMWare Workstation 6.52 Virtual Machine, I am unable to connect to port 80 on any remote site (google.com, etc).

I can ping remote sites, but anything over port 80 will not connect.

For example,

sudo apt-get update

... will eventually time out.

wget http://google.com

... resolves google.com to 74.125.45.100:80, but then will time out.

ping google.com

... works normally. I can ping any site.

My Host OS is Windows 7 Build 7068. I have checked if it's Host firewall by disabling the firewall entirely, and also ensuring that any VMWare entries in the exceptions list are allowing port 80 incoming and outgoing (the entries are actually set to allow all traffic on all ports).

Interestingly, if I have both a Server VM and a Desktop VM both running, I am able to access the webserver of the Server VM from the Desktop VM through Firefox using the Server VM's ip address.

So, inter-VM port 80 access works normally, but remote host port 80 does not work.

The Network Adapters for each VM are in NAT mode.

Any ideas?

EDIT - RESOLUTION:

It turns out this is a bug with VMWare 6.52 running under Windows 7 beta. The resolution is to switch to bridged mode. I had to manually assign the IP settings for the VM network adapter from inside Ubuntu to get Bridged mode working, as DHCP would not work.

share|improve this question
add comment

2 Answers

In NAT mode the firewall software of the host OS is managing the communication of the virtual machines to the world. Inside the host (e.g. from your guest desktop to your guest server) the communication doesn't go through the firewall. But the communication should be blocked by the firewall of the guest OS too. I suggest to change the network interfaces to bridged mode first. It will by-pass the firewall of the host OS. If the communication is working now you should configure firewall exceptions on the firewall of your host. If still doesn't work, check the firewall config on the guest. (it is unlikely the firewall of the guest blocks the communication because it works to the guest server) And you should have other firewalls over the host so anything can block your communication.

share|improve this answer
add comment
up vote 1 down vote accepted

It turns out this is a bug with VMWare 6.52 running under Windows 7 beta. The resolution is to switch to bridged mode. I had to manually assign the IP settings for the VM network adapter from inside Ubuntu to get Bridged mode working, as DHCP would not work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.