Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've got a FreeNAS install I've been using for a while, and wanted to set it up to serve as a network boot server. I downloaded and installed the isc-dhcpd-server, configured the tftp+iscsi+etc servers (which do work), and then tried to run the DHCP server. However, it exited with Illegal Instruction, no matter what I did.

I believe this could be because I am missing some dependencies, however I cannot use pkg_add to correct this because it can never seem to connect to ftp.freebsd.org. I've done:

setenv PACKAGESITE ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-7-stable/Latest/

However, no matter what I do, pkg_add always does something like this:

 >pkg_add -rv isc-dhcp42-server                                    scheme:   [ftp]
 user:     []
 password: []
 host:     [ftp.freebsd.org]
 port:     [0]
 document: [/pub/FreeBSD/ports/i386/packages-7-stable/Latest/isc-dhcp42-server.tbz]
 ---> ftp.freebsd.org:21
 looking up ftp.freebsd.org
 connecting to ftp.freebsd.org:21

And just freezes on that. Is there any way to get isc-dhcp-server working on FreeNAS?

share|improve this question
    
You need to provide more information. I doubt you'll get an answer with such a terse description. –  Magellan May 21 '12 at 2:17
    
I've changed the question to address this –  Eli May 21 '12 at 5:31

2 Answers 2

It doesn't seem as though you downloaded and configured the dhcpd package properly. That may be why the package manager is reaching out to the repository...

You may have a local (server) or network firewall rule preventing communication on the two ports needed for the FTP transfer. Port 21 is the control port and port 20 is the data port for active connections.

You could change the connection scheme to use http://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-7-stable/Latest/ instead and try pkg_add again... Or you could check your firewall rules on the appliance.

Also, when you mentioned configuration, did you add any information to the dhcp server's configuration file?

share|improve this answer
    
I changed PACKAGESITE to one that supported http, however it still stalls at "connecting," and eventually says "Protocol not available." I also created a firewall rule to allow all connections, however it still does the same thing. –  Eli May 27 '12 at 19:56
    
If you have another FreeBSD system, you might try to download/build the packages there and copy them to the FreeNAS –  arved May 29 '12 at 12:35

If you have troubles, fetching packages via FTP try setting MASTER_SITE_OVERRIDE in your make.conf to a mirror that offers http.

share|improve this answer
    
I tried setting MASTER_SITE_OVERRIDE, however it doesn't actually seem to do anything. Make.conf didn't exist, so I just created one. Is there something I'm missing? –  Eli May 27 '12 at 19:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.