Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Centos 6 box with virtualised CPUs that is ready for installing a virtual OSs. I am installing remotely over SSH and my Centos 6 box has no GUI (no GNOME etc) so it's purely command line. The following command is starts of the installation just fine:

virt-install --nographics --name kvm3 --ram 768 --disk path=/home/chris/KVM/kvm3.img,size=12 --accelerate -c /home/chris/CentOS-6.2-x86_64-minimal.iso

I then get the following standard screen for Centos installation:

          +----------------------------------------------------------+
          |                  Welcome to CentOS 6.2!                  |
          |----------------------------------------------------------|
          | Install or upgrade an existing system                    |
          | Install system with basic video driver                   |
          | Rescue installed system                                  |
          | Boot from local drive                                    |
          | Memory test                                              |
          |                                                          |
          |                                                          |
          |                                                          |
          |                                                          |
          |                                                          |
          |                                                          |
          |                                                          |
          +----------------------------------------------------------+

and I hit Enter and get:

Loading vmlinuz......
Loading initrd.img................................ready.
Probing EDD (edd=off to disable)... ok

then a load of whitespace and then this:

?

which is pretty uninformative. My guess was that it was trying to load the GUI installation or something? I have tried the --nographics option though.

Any ideas? Many thanks :).

share|improve this question
    
Have you tried hitting Tab instead of Enter and adding " text" then hitting enter? That's how I've entered text mode for previous 6.x versions in the past. Not sure if it will work for this. –  Chris Kaufmann May 16 '12 at 21:29

1 Answer 1

The trick is telling Anaconda (the installer) that your are doing a serial port install. Add the keywords "serial console=ttyS0,57600" to your install line ("console" is for the kernel, and "serial" is picked up by Anaconda).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.