Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As per this document I've created a profile in:

%windir%\system32\WindowsPowerShell\v1.0\ Microsoft.PowerShell_profile.ps1

When I run the 64 bit version of PowerShell the profile doesn't load. However when I run the x86 version the profile loads correctly.

How can I get my profile to load correctly in the 64bit version.

share|improve this question
What did you put in the profile? – Bart De Vos May 14 '12 at 12:29
For the time being it is just a test. So function test() { Write-Host "TEST" }. I've tried this on my machine, a colleagues and a server and I'm getting the same behaviour in all instances. – James Hay May 14 '12 at 12:32

This issue was a strange one in that after initially creating the profile in powershell I used notepad++ to edit the file.

It looks like there's a bug in notepad++ where by it looks as though you're editing and saving the system32 version but you're actually editing the version is systemWOW64 (also documented by someone else here

If I edit and save the profile in notepad the script runs as expected.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.