Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The hard limit of the number of open files is set to 1024 on my machine.

  • I changed /etc/security/limits.conf and added 'idror hard nofile 65000'.
  • In my shell I tried ulimit -n 65000. I get 'ulimit: value exceeds hard limit'
  • In my shell I tried ulimit -Hn 65000. I get 'ulimit: can't raise hard limits'

So how can I increase the setting for the limit of open files without reboot?

share|improve this question
    
After a limits.conf change, you need to log out and back in. – David Schwartz Nov 15 '12 at 0:57

You can just change it as root. For example:

$ ulimit -n  
4096
$ ulimit -n 8192
bash: ulimit: open files: cannot modify limit: Operation not permitted
$ sudo bash                    
# ulimit -n                    
4096
# ulimit -n 8192                  
# su - normaluser                 
$ ulimit -n                       
8192
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.