Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I can't get the Ubuntu server 12.04 ISO to boot in XenServer 5.5.

It is not a problem with the ISO or the share because I have used the iso to install locally and I can install other ISOs from the same share.

I imagine it has something to do with the template because one isnt installed for this version of ubuntu. I am creating the VM using "Other install media" as the template.

share|improve this question
    
What error are you getting? Have you installed the Linux pack? –  Dan May 15 '12 at 14:13
    
I'm not seeing any errors (unless I'm looking in the wrong spot). It just shutsdown after printing "Initializing gfx code..." or sometimes it stops at the step before when it prints "Loading bootlogo..." –  zeal May 15 '12 at 14:17
    
Have you installed the Linux Support / Supplemental pack? –  Dan May 15 '12 at 14:18
    
No, I didn't know about the Linux pack. I'm not sure if a person before me installed that. I do have ubuntu 4 running currently on the server. –  zeal May 15 '12 at 14:20
1  
I don't have a XenServer near by, but try running "xe host-list params=all" on the console. If the Linux Pack is installed, it should show up, though I'm not 100% convinced it's your issue, it's a good first step. I think it shows up as "package-linux: installed" –  Dan May 15 '12 at 14:29

2 Answers 2

up vote 3 down vote accepted

Zeal, what I have done to get virtual Ubuntu hosts is to first follow the steps on this website. This will give you an Ubuntu 10.04 Template, I then used this template with newer version's of Ubuntu server via an ISO. Although you may be best to just run 10.04 to avoid any complications which may crop up in the future.

I also thought it might be worth mentioning to you one of the main issues I find with Ubuntu machines running in XenServer; Rebooting a hung HVM in XenServer.

share|improve this answer

Press F6 at the ISO's grub menu (Before selecting 'Install Ubuntu Server') for extra boot options

Select ACPI=OFF

share|improve this answer
    
Solved it for me! –  scaryman Jan 11 '13 at 16:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.