Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is a very strange problem. We recently upgraded our cloud service. Our host migrated our entire VM with all settings and files unchanged. I updated the IP address at our named provider and have verified that it resolves to the new IP address. When I try to access the domain Apache refuses the connection. The VirtualHost is unchanged and worked before. I tested another domain that we have on this server and Apache returns the data as expected. I removed all the mod_rewrite rules for this domain and pointed it to a static html directory but Apache still refuses the connection. I can confirm that this problem only exists with this particular domain. We are running CentOS 5.6. This is not running through https and there are no certificates involved. Here is my VirtualHost entry:

<VirtualHost *:80>
ServerName domain.com
DocumentRoot /home/site
</VirtualHost>

UPDATE: Silly me, I forgot that I had set my local /etc/hosts file to the previous IP when I made my previous move. How could I miss this.

share|improve this question
    
Did you check your error.log? Maybe the new IP address has not yet made it into DNS (due to TTL settings). –  Oliver May 15 '12 at 14:31
    
When you say Apache refuses the connection, what does this mean? are you getting any error code on page like 404 or 500 or are you getting page not found –  sandeep.s85 May 15 '12 at 14:31
    
I solved it after running it through curl on another server. It was a local problem with my /etc/hosts file. –  Hawkee May 15 '12 at 14:42
    
Thank you for responding, but I figured it out. It was a problem with my local /etc/hosts file, doh! –  Hawkee May 15 '12 at 14:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.