Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to create a subdomain alias on my DNS server to have portal.domain.com instead obscureServer32324name.domain.com I've attempted both a a CNAME alias to the exact A host entry or creating a second A host entry for the same server IP and neither of them allow me to get a response back from even running ping right on the dns server.

Am I missing something that I need to do after adding these records to dnsmgmt like being required to start the dns service?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Create the CNAME record "portal.domain.com" referring to "obscureServer32324name.domain.com" in the "domain.com" DNS zone. From a command-prompt, do a:

nslookup portal.domain.com

What do you get back?

Bear in mind that if "domain.com" is an Active Directory-integrated zone you could have a slight delay before the DNS server begins to resolve it.

Also on the Active Directory integrated DNS front, bear in mind that your DNS client might not be trying to resolve against a DNS server that's "looking at" the same copy of AD where you added the record (via DNSMGMT) a moment before. Force AD replication or wait 5 minutes for AD replication to complete.

You don't need to stop / restart the Microsoft DNS server for changes like this to "take".

Edit re: your comments:

Bizarre. I'm at a bit of a loss. That's a pretty common configuration, so it ought to work fine. I have several Customers with servers that are configured just that way (w/ CNAME records like "WSUS" or "antivirus", etc).

The computer you're testing from is configured to use the server computer where you added the CNAME as its DNS server-- correct?

Do the following, just be sure that you're querying out of the right zone:

nslookup -querytype=SOA domain.com

You should get back something like this:

domain.com
        primary name server = server.domain.com
        responsible mail addr = hostmaster
        serial  = 425
        refresh = 900 (15 mins)
        retry   = 600 (10 mins)
        expire  = 86400 (1 day)
        default TTL = 3600 (1 hour)
server.domain.com     internet address = 192.168.1.1

Be sure the SOA record that you get back really is referring to the server computer you expect to be seeing the zone hosted from.

We'll figure it out, it just may take a moment.

share|improve this answer
    
*** obscureServer32324name.domain.com can't find portal.domain.com: Non-existent domain –  Chris Marisic Jul 10 '09 at 15:05
    
Your instructions are exactly what I have done but for some reason it just seems to act as though I never do it and I clearly see the CName record in the zone right next to the A record for the machine I'm trying to alias. –  Chris Marisic Jul 10 '09 at 15:06
    
I suppose I could add 1 more bit of information incase it makes any importance, the machine in question is both the DNS Server, and DC and target of the CName. –  Chris Marisic Jul 10 '09 at 15:15
    
When I run the nslookup for the SOA that is actually returning results from the internet where we have our company website hosted externally however on the intranet the server I'm trying to alias is setup as the SOA and name server and if I run an nslookup on it's uri obscureServer32324name.domain.com it does stay within the intranet and returns the same ip as localhost would. –  Chris Marisic Jul 10 '09 at 16:03
    
Zow-- KAPes answering this made me "remember" it. This is an utterly confusing situation, but I think that KAPes is on to it. My guess is that you're creating the record in a DNS server internal to your network, then querying an Internet DNS server looking for that record. –  Evan Anderson Jul 23 '09 at 23:31
show 1 more comment

Looks like there different DNS servers involved. one where record is created and one from which record is queried.

I think you are creating record in internal DNS server and your clients are not configured to look at that DNS server.

Is it possible for you to this ?

  1. Get the DNS server IPs configured in your client machine
  2. logon to that DNS server and if domain.com zone is present there create CNAME entry there.

If you are not able to do it

can you give output of following commands

Machine from which you are querying the DNS

ipconfig /all 
nslookup portal.domain.com
nslookup -q=NS domain.com
share|improve this answer
    
Yes this is for an internal DNS server, yes the clients are configured to use the DNS server. I'm on the actual dns server remotely and can't get the resolution to occur even. –  Chris Marisic Jul 24 '09 at 15:19
    
then is your DC configured to look at itself as primary DNS server ? –  KAPes Jul 25 '09 at 7:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.