Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I set chroot_local_user to YES in the vsftpd configuration, I get this error in my ftp client:

220: (vsFTPd 2.3.5)
Connected to 23.21.50.255.
Cmd: AUTH TLS
234: Proceed with negotiation.
Cmd: USER ftpaccess
331: Please specify the password.
Cmd: PASS xxxxxxxx
Could not read reply from control connection: Unknown error: 0.

And this in the /var/log/vsftpd.log file:

Wed May 16 04:51:42 2012 [pid 2] CONNECT: Client "68.224.80.95"
Wed May 16 04:51:43 2012 [pid 1] [ftpaccess] OK LOGIN: Client "68.224.80.95"

If I remove write access to my home directory, I do not receive the error and am able to connect. How can I enable chroot_local_user with write access to my web directory?

share|improve this question
    
This could be related to using TLS with chroots, try connecting without TLS to rule out or confirm this. –  mgorven May 16 '12 at 20:37

1 Answer 1

I see the same issue here and, indeed, it seems to be related to TLS and chroot... I used to have this working on older instances of vsftpd (last checked 2.0.5).. this fails for me with 3.0.2

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.