Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The system clock on a CentOS 5 install is running twice as fast as it should. The hardware clock is fine, and when I run a ntp sync, it resets to the correct time. But within 2 minutes, it is already 2 minutes too fast. The OS is not running virtualised, this is a native CentOS install on an AMD Opteron server.

Any clues?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Can you provide the specific version of CentOS 5 as well as the server manufacturer and model. That may help...

But one thing you can try on CentOS 5 is appending clock=pmtmr to the end of your kernel boot line in the Grub menu or in /etc/grub.conf and restarting the system. Explanation here.

share|improve this answer
    
Adding this seems to have helped, it has been running normally for the last hour. Thanks for your help. –  Daryl May 16 '12 at 12:45
  1. Is the server BIOS/firmware the latest version? Try to upgrade that and see if it helps.
  2. Is your CentOS 5 install up-to-date? If not and you can upgrade it, do it and see if some kernel upgrade resolves your issue.
  3. If everything else fails, try one of these as boot parameter in GRUB kernel line: clocksource=pit, clocksource=tsc, clocksource=acpi_pm
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.