Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was setting up a server until about a month ago when I had to stop for personal reasons. I've went back to it today and tried to send/receive emails.

Initially, I sent myself an email from my Gmail account to an email account on my server and I received it successfully. However, when I have gone to reply back to that email I haven't received it in my Gmail account and nor have I received a bounce email to my email account on the server.

However, I have tried two more times to send emails to the server from the Gmail account and they haven't been received. I have also sent an email to the Gmail account again and again neither the message or a bounce message has been received.

I have checked the Postfix mail queue, and it shows the following information: enter image description here

I have also checked the mail log, and I get the following error:

May 16 15:58:43 setanta postfix/smtp[9231]: DC06A122: to=<michael@gravex.co.uk>, relay=127.0.0.1[127.0.0.1]:10024, delay=1542, delays=1242/0.01/300/0, dsn=4.4.2, status=deferred (conversation with 127.0.0.1[127.0.0.1] timed out while receiving the initial server greeting)

Does anyone have an idea about what's going on with this?

Many thanks in advance!

EDIT
Here is the main.cf file. This is all uncommented, so if there is something missing here then it's either not included or I have it hashed.

queue_directory = /var/spool/postfix   
command_directory = /usr/sbin    
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
mail_owner = postfix
inet_interfaces = all
inet_protocols = all
mydestination = setanta.gravex.co.uk, localhost, localhost.localdomain
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
         PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
         ddd $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.6.6/samples
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
myhostname = setanta.gravex.co.uk
mynetworks = 127.0.0.0/8 [::1]/128
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_use_tls = yes
smtpd_tls_security_level = may
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = maildrop
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
relayhost =
mailbox_size_limit = 0
message_size_limit = 0
share|improve this question
    
Can you post your postfix main.cf file. Just the uncommented lines. –  Chakri May 16 '12 at 17:42
    
Amend that to postconf -n, and the logs from one entire message from connection to queue removal. –  adaptr May 18 '12 at 15:39

1 Answer 1

You are sending mail to a service that postfix expects to be running on port 10024.

This process is not listening on port 10024; perhaps it is not running ?

share|improve this answer
    
Are you referring to postfix? It is set to start when the server starts and I've also stopped/restarted the service so it does run. –  mickburkejnr May 21 '12 at 15:00
    
I am talking about this: relay=127.0.0.1[127.0.0.1]:**10024** –  adaptr May 22 '12 at 8:06
    
Sorry I know what that is. I've updated my answer. –  mickburkejnr May 22 '12 at 8:37
    
WHat answer ? I thought you had a question - and you haven't done what I asked yet. –  adaptr May 22 '12 at 11:08
    
Sorry, having internet problems atm. Amavisd wasn't running but thats caused another issue. Will update later today. –  mickburkejnr May 22 '12 at 11:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.