Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to create a scheduled backup on a Server 2008 R2 box (using the built-in Windows Server Backup UI). Whenever I run a backup manually (image or otherwise), it works perfectly. When I try to schedule the same backup I get all the way to the end and it pops up an error saying:

Logon failure: unknown user name or bad password

I'm copying to a network drive via a UNC path, but I've confirmed the user/pass I'm entering there are correct (if entered wrong it immediately prompts again). Once this error pops up, I hit OK and the status just says "The backup schedule was not created."

As a final note, this had been tried under both the built-in administrator account and a separate admin account. It's a standalone box (no domain) and both accounts I've tried under are part of the local Administrators group.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

I believe (but don't quote me) that Windows Backup on Windows Server 2008 R2 uses the task scheduler. You should be able to check the task scheduler and set which login account the scheduler is using. It might just need the password. Though typically it will run under a "system account", that has the necessary privledges.

You will probably need to find an account that has access to the UNC and has local admin privledges on the box you are backing up. I believe that you can use teh same username and password on both and it should work so long as you set the Username and password in the task manager to match.

share|improve this answer
    
Normally either domain or local administrator will be able to give you need privileges. –  George May 16 '12 at 22:43
    
Are you referring to the "AT Service Account Configuration" section inside Task Scheduler? If so, that is set to "System account" already. The location of the backup for the UNC path is something provided to me by my hosting company (this box is a VM) with a specific user/pass, however that is the only thing I don't have control over. I am able to login locally on the box I'm trying to backup as an admin (it's not on a domain) and it's during this configuration that I get the error. I have no trouble accessing any other resources and have other scheduled tasks that run fine as-is. –  digitall May 16 '12 at 22:55
    
then that is probably your problem. The System Account is a local account to that machine and won't have access to the resources at the UNC path. There are several workaround for this, but easiest is probably to add the user account with matching credentials to the local users account, add that person to the back admins group on the box. Then run the backup under that user account in the task scheduler. That way when the task runs, it will pass the credentials to the remote machines hosting the UNC and grant it access to store the backup there. –  MikeAWood May 17 '12 at 0:23
    
The user I was logged in with had the same username as the UNC share I was going to so I just changed the password for the local account to be the same as what the UNC share required and scheduling worked fine. Thanks for the help! –  digitall May 19 '12 at 3:46
    
Woot... glad to have been helpful! –  MikeAWood May 22 '12 at 0:38

Have you tried using the CLI c:\windows\system32\wbadmin.exe? I backup to a share which I give to wbadmin.exe on the command line, with a username and password. I use Bacula as the scheduler, but you could create your own task in Task Scheduler.

The CLI version is also a lot more verbose, or so it seems as you get a chronology of status messages and path to two files at the end, one containing output (stdout in Unix) log and another error logs.

One other thing to consider when using Windows Server Backup is that you cannot backup less than once a day, for example once every two days. By using the command line you can choose to do backup however less frequently you want! Remember that with backups to a share, you do not get incremental backups. The latest backup overwrites the past backup and consequently if your latest backup is stuffed, so is your only backup of the server.

This might all be advice that you've heard before. My 2c of experience as I've just finished setting up backup in my infrastructure with too-many-to-count W2K8R2 and W7Pro machines.

share|improve this answer
    
neorora: One workaround in the GUI for the missing durations is to type in the duration by hand. Even though the GUI has dropdowns, it will let you hand enter durations other than in the list. Though I agree, the CLI is much quicker for setting up many servers all at once. –  MikeAWood May 17 '12 at 0:28
    
@MikeAWood: I am talking about doing backups at a lower frequency than the one permitted by Windows Server Backups. So, less than once per day, i.e. once every week for example. –  nearora May 17 '12 at 0:51
    
You can do that in the wizard, you select daily then on the next screen it asks "every x days". you can also do this in the GUI once the task is setup by editing the trigger. If you have an irregular schedule, you would need to probably create additional trigger events that correspond to some repeatable pattern. If you are referring to the same option as /DU from the, you can edit those in the trigger as well by manually typing it into the drop down. (though it seems very counterintutive to do so) –  MikeAWood May 17 '12 at 1:02
    
@MikeAWood: Mate, I think we might be talking of different things. I am talking about the Windows Server Backup wizard on W2K8R2 and you are most likely talking about the Task Scheduler. –  nearora May 17 '12 at 1:41
    
correct, I am talking about the task scheduler. When a Windows Backup job is scheduled, that backup job is added to the task scheduler in Windows. (Wizard or CLI) So if you have an abnormal backup schedule for backup, you can change it from the task scheduler. You can find the backup task in Windows 7 task scheduler in "Task Scheduler\Microsoft\Windows\WindowsBackup" . On Server 2008R2 it is in "Task Scheduler\Microsoft\Windows\Backup". Though, admittedly, I opted to use the CLI instead to do my setup as well as I am using a NAS for the backup destination. –  MikeAWood May 17 '12 at 19:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.