Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am getting this error when I am setting up a ASP.NET MVC3 application onto an IIS server.

HTTP Error 403.18 - Forbidden

The specified request cannot be processed in the application 
pool that is configured for this resource on the Web server.

However the strange thing comes from below; detailed error information:

Module IIS Web Core

Notification

BeginRequest

Handler
PHP53_via_FastCGI

Error Code
0x00000000

Requested URL
http://localhost:80/index.php?q=OCOM/Account/LogOn

Physical Path
C:\inetpub\wwwroot\index.php

Logon Method
Not yet determined

Logon User
Not yet determined

Is there some kind of 'misconfiguration' whereby the PHP engine somehow interpreted the ASP.NET MVC3 request into a php one? Frankly I don't really understand what went wrong as my local machine works fine with a similar setup (installed PHP, etc. using Microsoft Web PI)

share|improve this question

2 Answers 2

I'm guessing you have URL Rewrite setup in the root of your website for index.php.

So, if you're running your MVC application in a subdirectory, you can unregister that index.php URL rewrite for that subdirectory.

To do this, just open up IIS manager, click on the subdirectory under your website, and use the "Filter:" box to type "rewrite" and it'll let you get into the URL Rewrite config area.

Then you'll probably see a rewrite rule listed there that you'll want to select (click once) and hit "Disable rule" on the right.

OK?

share|improve this answer

Look at the Handler mappings for that site/directory. You should see an entry for PHP53_via_FastCGI. This should remove the FastCGIModule.

...or you can just add this to your web.config

Or you can just add this to your web.config

<handlers>
    <remove name="PHP53_via_FastCGI" />
</handlers>

This should work for any handler. Some of you might be getting for a different version or different handler complete. Just replace "PHP53_via_FastCGI" with whatever it is. (ex. PHP60_via_FastCGI)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.