Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am in the process of packaging an some software settings for deployment with a GPP. I need to include a few tab characters within string and eventually multi string values.

When I paste tabs into the GPP item they are translated into spaces on the client (7, 2008R2 systems).

Replacing the tab with \t, 0x09 or 	 doesn't work as they are treated literally. Is there anything I can do to get these characters included?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

This appears to be a bug with how the encoding from the Group Policy console to the Registry.xml is run. If I open the Registry.xml with an editor and replace the tabs with the value 	 the policy works as desired.

This is hardly an adequate solution - changing the policy in Group Policy Editor will break it again - but it is the best I've found.

I'm seriously considering setting up a script to periodically change this file and to keep it in sync.

I started a topic on the technet.. Maybe MS will do something about it.

share|improve this answer

I've done some testing and can replicate the issue. As far as I can see, the only workaround is the one you've posted - modifying the Registry.xml and scripting it for next time.

This is probably a bug (or possibly a "working as intended") by Microsoft.

Sorry I can't help more!

share|improve this answer
    
Thanks Whitey, good to see this extends beyond my environment. –  Tim Brigham May 22 '12 at 11:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.