Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to upgrade some old Fedora 13 servers to Fedora 14 following Fedora's docs. The yum commands ran very quickly and seemingly without error. However, when I rebooted after finishing the upgrade to Fedora 14, I found the server was completely offline and I couldn't SSH into it. Logging in manually revealed that the eth0 interface had not been brought up automatically.

My ifcfg-eth0 looks like:

DEVICE=eth0
BOOTPROTO=static
DEFROUTE=yes
DHCPCLASS=
DNS1=10.157.10.12
GATEWAY=10.157.10.1
HWADDR=00:0D:12:34:56:78
IPADDR=10.157.10.18
IPV4_FAILURE_FATAL=yes
IPV6INIT=no
NETMASK=255.255.255.0
ONBOOT=yes
OPTIONS=layer2=1
PEERDNS=yes
PEERROUTES=yes
TYPE=Ethernet
UUID=5fb16cd0-0bb1-8ffb-45f1-d6edd65f3e02

Running sudo ifup eth0 brought up the interface correctly, and the server appears to have no further issues with the upgrade. However, since I've specified ONBOOT=yes, why is the interface not being brought up automatically?

Edit:

[user@host ~]# chkconfig --list | grep -E "network|Network"
NetworkManager  0:off   1:off   2:off   3:off   4:off   5:off   6:off
network         0:off   1:off   2:on    3:on    4:on    5:on    6:off
share|improve this question

1 Answer 1

up vote 4 down vote accepted

If you run "service network start", does that start the interface also? If so, run "chkconfig --list" and look for "network" and "NetworkManager". I think that Fedora 14 added NetworkManager, which is intended more for desktops than servers, and either doesn't process, or processes differently the /etc/sysconfig/network-scripts files. In any case, you want to "chkconfig NetworkManager off", and "chkconfig network on" (assuming "service network start" worked properly).

share|improve this answer
    
Yes, the chkconfig settings were wrong. Also, it seems the upgrade didn't succeed, as the package "alchemist" had some broken dependencies that had created an partial upgrade, and that was somehow interfering with the network service. After I removed alchemist and NetworkManager and did a yum upgrade, that fixed everything. –  Cerin May 18 '12 at 15:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.