Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running IIS 7.0 on Windows server 2008 R2 and created 1 Application Pool per site and I have several site which is causing the application pool to stop.

This shows several times for every applications:

A process serving application pool 'ivtaxi.com(domain)(2.0)(pool)' terminated unexpectedly. The process id was '5584'. The process exit code was '0xc0000374'.

A process serving application pool 'atkinsforassembly.com(domain)(2.0)(pool)' terminated unexpectedly. The process id was '5456'. The process exit code was '0xc0000374'.

and when I check to server error log, the most often error is:

Faulting application name: w3wp.exe, version: 7.5.7601.17514, time stamp: 0x4ce7a5f8 Faulting module name: ntdll.dll, version: 6.1.7601.17725, time stamp: 0x4ec49b8f Exception code: 0xc0000374 Fault offset: 0x000ce6c3 Faulting process id: 0x398c Faulting application start time: 0x01cd340c88d38d70 Faulting application path: C:\Windows\SysWOW64\inetsrv\w3wp.exe Faulting module path: C:\Windows\SysWOW64\ntdll.dll Report Id: 9db95ac0-a000-11e1-9b71-0a4f65b29aaf

I have no Idea about this server fault, anyone can help me here? :( I need a heroes..

share|improve this question

closed as not a real question by Chris S May 18 '12 at 12:51

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What's your application, Classic ASP? ASP.NET? Is the worker process configured for 32 bit or 64 bit mode? Is it configured to run in classic or integrated pipeline mode? You need to supply these details. –  Kev May 18 '12 at 1:14
    
I think the issue come from Classic ASP application, because I have ASP.NET and classic ASP applications on my server. –  vantian May 18 '12 at 4:28
    
@vantian My apologies but we really need more detail to be able to help you. Also, Server Fault is for Professional System Administrators only, you seem to be a developer; regardless we need to see a reasonable level of professional effort put into solving the issue, and that should be reflected in the question. See the FAQ and How to Ask for details. If you can edit the question and add enough detail that someone might be able to help, we'll gladly reopen the Question. Thank you! –  Chris S May 18 '12 at 12:54
    
Hi Chris, thanks for the respond..I'm so blind to solve this problem..I will ask my support to get the details soon, –  vantian May 18 '12 at 19:50
    
this is the details, I have a asp.net and asp classic applications running on Integrated pipeline mode. –  vantian May 18 '12 at 20:51