Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I get a beep that sounds like a BIOS level, at VERY loud volume, when in an MSTSC session to a server.

Which when I am listening to some audio, is almost deafining in volume. I often jump and curse at the volume of it!

Is there anyway to disable this? There is no sound card on the Windows servers, and thus no volume to turn down.

Worst is that within the Active Directory Users and Computers snapins, if I have a Find window open, and click on the background ADUC, I get one of these beeps, and it HURTS!

Any hints on how to shut that beeping down? (Same on deletes of users, and other actions).

Client is WinXP SP3, target is Win2K8 and others.

share|improve this question

7 Answers 7

up vote 6 down vote accepted

I don't know OS you are using and accessing, but does this help? Disable System Beep in Windows Vista

Looks like there is a system device that controls that particular beep.

share|improve this answer
    
I am actually running WinXP SP3, connecting to a Win2K8 server, and that did the trick! My ears thank you!!!!!!! –  geoffc Jul 10 '09 at 17:55
    
You are very welcome, I am sure I'll need the same trick eventually :) –  Matt Jul 10 '09 at 18:00

In MSTSC/Remote Desktop, before you connect, click Options, Local Resources. Then choose "Do Not Play" under Remote Computer Sound.

alt text

share|improve this answer
    
Just tried it, still did not work! Do Not Play and still deafining beeps. –  geoffc Jul 10 '09 at 17:41
    
-1 because it did not work! :) Nah, I will take that back, since I thank you for the effort! –  geoffc Jul 10 '09 at 17:41
    
Also tried Leave at Remote Computer. Still beeping. –  geoffc Jul 10 '09 at 17:42
    
Astonishingly, it is a service on MY machine, the Beep service that is at fault. I never would have suspected that! Always assumed it was the machine I was connecting too. –  geoffc Jul 10 '09 at 17:56

disable for session:

net stop beep

disable for good:

sc config beep start= disabled

note this disables the beep service on your local machine!

share|improve this answer

Is this any good ?

share|improve this answer
    
I used the GUI approach suggested in the Accepted Answer, but I suspect that the options in this article are the same basic result, using more command line/registry approaches. Thank you very much for your comment! –  geoffc Jul 10 '09 at 17:56

Geoffc. Sign into your server. Bring up Terminal Services Configuration. Edit the RDP settings on it, you can stop it from sending sound, clipboard, etc.

Disable sound.

if you still get it, disable sound in the bios! See link below. http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/73767bca-021b-480f-9001-fffaae2220da

share|improve this answer
    
Nope, in this case, the accepted answer was correct. Doing what you suggest at least from the RDP issue did not help. Since I will be connecting to stacks of servers, BIOS disabling is probably not an option. But the Beep device was the trick! –  geoffc Jul 13 '09 at 1:17

You can turn off remote computer sound during a session. After running remote desktop go to the options and under the "Local Resources" tab there is "Remove computer sound" set this to "Do not play".

share|improve this answer
    
As the nicer answer with the screen shot, it does not work! Still beepity-beeping, and killing my ears! –  geoffc Jul 10 '09 at 17:42

When you fire up MSTSC, before you connect to the remote box, click on Options --> Local Resources, and there is an option for "Remote Audio." You can click on Settings and choose "Do not play" for Remote audio playback.

share|improve this answer
    
As the nicer answer with the screen shot, it does not work! Still beepity-beeping, and killing my ears! –  geoffc Jul 10 '09 at 17:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.