Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running ubuntu 12.04. On this machine I have Webmin 1.580 installed. When trying to add a new module to Webmin I receive an error: "Failed to install module from : File does not exist"

This happens when i go to Webmin Configuration > Webmin Modules > Select "Third party module from" > Select "OpenVPN admin tool" and clicking on install module

After I selected "OpenVPN admin tool" this url is being added: http://www.openit.it/downloads/OpenVPNadmin/openvpn-2.5.wbm.gz

This URL resolves to a correct file.

When uploading the file directly, the same error occurs.

In the log file: /var/webmin/webmin.log nothing special is reported.

How can I fix this issue?

P.s. I run this server in CLI mode

share|improve this question
    
Is there anything in your apache error log? –  KayakJim May 18 '12 at 13:05
    
No, there is nothing in my appache error log. Though I found a solution, when downloading the module file to my server using wget, I can browse to it locally. After that the module installed without any problem. Probably the directory webmin writes to has no valid write rights. –  Arthur May 18 '12 at 15:01
add comment

1 Answer

A little late to the parade but I ran into the same problem and was able to get past it so I post it here for others that may run into it.

This installed it fine for me on Ubuntu 13.04 x64

Reference >> Install Webmin And OpenVPN On Your Cloud Server

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.