Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running an Apache server with Suexec. However, I get an internal server error if I try to execute a CGI script that is group-writeable (if I chmod g-w , the script runs fine)

However, I want the file to be group-writeable. SuPHP has a config option that allows me to do this, but I can't find the analogous option for Suexec. How can I run CGI scripts that are g+w?

share|improve this question
up vote 1 down vote accepted

This is an explicit check which suEXEC does, and can only be removed by modifying the source code (which is not recommended).

share|improve this answer
    
I ran into the same problem. Too bad suEXEC cannot run cgi files with any permission other than 755 (assuming this is the case). – Leo Galleguillos Jun 5 at 7:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.