Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running ubuntu 10.04, since I upgraded to mysql 5.5 it stopped starting at bootime. I tried sysv-rc-conf mysql on because it was actually set to "off" but still won't boot. I have to manually run service mysql start everytime which will make it start in 2 seconds, also the log shows no errors!

share|improve this question
Are there any log messages indicating that the system tried to start it during bootup but failed? – mgorven May 19 '12 at 23:12
nothing, I just tried to reboot and there's no trace of mysql – Sandro Antonucci May 20 '12 at 22:37

Go and edit


and be sure that you have the lines (somewhere near the top, check if they're not commented):

start on (net-device-up
      and local-filesystems)

Meaning that it will start when networking is up and local filesystems are mounted.

share|improve this answer
it was already like that – Sandro Antonucci May 20 '12 at 17:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.