Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Dell R310 server. Installed CentOS 6.2 (minimal) and it won't boot. It hangs at the following error.

/bin/sh: error while loading shared libraries: /bin/sh: supported version 25416 of Verneed record

init: rcS pre-start process (405) terminated with status 127

It runs CentOS 5.8 just fine. I don't know what the error means or how to fix it. I wish I had more information but I'm stuck at this point. Any ideas?

An output of dmidecode is here: http://pastebin.com/4GVwcnG9

EDIT: Turns out this may have just been a freak library / file corruption during install or something. A second fresh install worked perfectly.

share|improve this question
    
Is that the exact error message? That's the most esoteric error I've ever seen loading shared libraries. Looks like a mis-translation or something. –  Mat May 20 '12 at 8:59
    
What is your partition layout? Perhaps /usr isn't mounted and init isn't finding the necessary libraries? –  Bram May 20 '12 at 9:26
    
Yup, that's the last two lines displayed on the monitor when trying to boot. Then it's all locked up. This was a test installation with just one big partition for / and a small primary partition for /boot (about 200 MB). –  someotherguy May 20 '12 at 16:49
    
The very few references I found on Google to "Verneed record" concern bad compilation of some program and hardware problems. There's also a bug report indicating problems with a corrupt library. At this point I'd recommend to reinstall or try removing various hardware components as suggested on the startcom forum. –  Bram May 21 '12 at 13:18
    
@Bram Yup, I re-installed last night and now it works like a charm. Thanks! –  someotherguy May 21 '12 at 18:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.