Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed tomcat via an installation script from the apache solr typo3 community and spent the last 3 days trying to figure out why it won't work until by chance I noticed that when I queried the process listening on the port via "lsof -i", it was bound to the ipv6 protocol. I have googled everywhere and most say that setting address to in the tomcat connector resolves this issue, others say setting JAVA_OPTS=""; I have tried the former which doesn't work but the latter I am unsure of where to put it. One solution I read somewhere suggested to put it in but I can't find this file in my tomcat installation. I would appreciate any help at the moment regarding this. The tomcat version is 6.x and the OS is ubuntu 11.10. Thanks

share|improve this question
What ips/ports is it listening on, via lsof -i? – becomingwisest May 20 '12 at 19:01
@becomingwisest 8080. – Dark Star1 May 20 '12 at 22:50
You are correct - file does not exist out of box. You need to create file in your CATALINA_BASE or CATALINA_HOME bin directory. The startup scripts check if you created the file, if you did create customization ( file - startup script calls it, otherwise just ignores, and moves on. – nevenc Aug 14 '15 at 12:03
up vote 20 down vote accepted

Ok I finally solved it. I was directed to try this and Henk's solution. Neither of which seemed to work with the remote virtual server. I'm guessing the fact that because I'm on a shared kernel space so the provider prevents this. In any case I added: JAVA_OPTS= $JAVA_OPTS to the startup script and that seemed to have fixed the issue of binding tomcat to ipv6.

share|improve this answer
So you're on a VPS with a shared kernel... D'oh! – Henk May 21 '12 at 12:58
This seems not to work anymore with tomcat 8. – Ortomala Lokni Jun 22 '15 at 9:42
With tomcat 8, this option didn't work for me, but nevenc's answer did work. – Edenshaw Feb 1 at 20:56

Many suggested updating startup script. Yes, that solution would work, but script is not meant to be customized/updated. All changes should go into the customization script instead, i.e.

NOTE: TOMCAT_HOME/bin/ doesn't exist by default, you need to create it. Check the script and you will see the startup script checks if exists, and executes if it does.

So, I suggest you create new TOMCAT_HOME/bin/ script with a single line:

share|improve this answer
I would also use CATALINA_OPTS instead of JAVA_OPTS, especially if you have other JVM options you want to pass into JVM on Tomcat startup. If you use JAVA_OPTS, the same options will be passed into Tomcat shutdown, probably not what you would want/expect. Use CATALINA_OPTS instead :) – nevenc Aug 14 '15 at 12:01

If you used this installer: "Apache Solr for TYPO3", you can change the address in the file server.xml.
The default points to localhost, so look for and change it into the IPv4-address you want.
Don't forget to restart Tomcat6 for the changes to take effect.

UPDATE, 20120521

See my comment below on how to disabe IPv6 on Ubuntu 11.10.

I have succesfully tested this on a Virtualbox-VM on my Mac.
The address for the connector port 8080 has been changed from to in server.xml.
Then disabling IPv6 makes the "tcp6" to go away, so it's binded to an IPv4-only address.

Before / with IPv6 enabled:

# netstat -anp | grep 8080
tcp6 0 0 :::8080 :::* LISTEN 1972/java

After / IPv6 disabled:

# netstat -anp | grep 8080
tcp 0 0* LISTEN 2045/java

share|improve this answer
Tried this also and that didn't work netstat shows that despite the process being bound to an ipv4 address it's still looking for an ipv6 a la this return: tcp6 0 0 X.X.X.X:8080 :::* LISTEN. which I think is odd but the problem has also been replicated on my friend's vm which is hosted on a mac. – Dark Star1 May 20 '12 at 22:46
And when IPv6 is disabled? Here is a howto for Ubuntu 11.10: – Henk May 21 '12 at 7:29

The correct syntax for modifying would be:

share|improve this answer

While probably not the preferred method, I have observed that disabling IPv6 at the kernel level will convince Tomcat to open an IPv4 bind.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.