Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a centos 6.2 machine tried to yum install monit it says nothing to do. Then I have a link here http://pkgs.repoforge.org/monit/. Is this a reliable site or any other better suggestion? Thank you.

share|improve this question
    
user111196, you've asked 19 questions on SF, most of them have at least one answer, and you've accepted the answer for very few of those. We see this as a warning "23% accept rate" by your username. May I suggest that you spend an hour or two reviewing your past questions, and accepting answers where you can? It drives the SF reputation system both for you and those who try to help you, and it's the polite thing to do. –  MadHatter May 21 '12 at 10:32
    
@MadHatter sorry for that now I have done most of it ready. –  user111196 May 21 '12 at 13:08
    
Much better - the community thanks you! –  MadHatter May 21 '12 at 13:58
    
@mad now worries we work together and learn together –  user111196 May 26 '12 at 5:28
add comment

2 Answers

up vote 4 down vote accepted

I would use the EPEL repository.

share|improve this answer
    
does it comes with monit in it? Is it stable enough based on your experience? –  user111196 May 21 '12 at 8:33
1  
The EPEL repository is a de-facto repository for the extra packages not found in base RHEL/CentOS repositories. It's probably your best shot, as EPEL packages do not overlap with base repositories and do not cause dependency problems. Also, the software there is very stable -- typically not the bleeding-edge versions, but the well tested ones. –  Janne Pikkarainen May 21 '12 at 8:38
    
And yes, of course it contains Monit, otherwise I would not have mentioned it. :-) –  Janne Pikkarainen May 21 '12 at 8:39
    
I download the file I run this command rpm -i epel-release-6-6.noarch.rpm warning: epel-release-6-6.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY There is a warning nokey is that something wrong here? Next I run yum intsall monit it works. –  user111196 May 21 '12 at 13:20
    
Totally legit. It just means you do not have the repo key in the rpm db yet (yum imports it the first time you use the repo). Of course, you should check the key matches the one published on the epel site. –  Alien Life Form May 21 '12 at 16:54
show 3 more comments

http://repoforge.org/use/ Will tell you how to add the repoforge repo to your yum. If, however, EPEL contains monit (I dunno) then it is more stable (in my experience) then repoforge.

share|improve this answer
    
life I will go with the epel then ok. Thank you. –  user111196 May 22 '12 at 1:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.