Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My azure website is working fine with http. Now, I have added a self-signed certificate and a binding in IIS 7. When I run the application with https, I get certificate error warning. When I confirm 'run anyway'. Then I get 'http service 503 unavailable' continuously only with https. My binding is correct(because I am seeing certificate error first time). No log found in IIS log files. Tried, IIS Failed-request tracing, no log found. I have confirm that iis user can register both port 80 and 443(using netsh). Any idea?

Edit: The site is now working if I use specific IP in binding. But when I chnage this to 'All Unassigned' I got the same error? why?

share|improve this question
    
Do you have another site in IIS? –  Shane Madden May 21 '12 at 22:43
    
@ShaneMadden, I have also checked with just one 1 running site –  user960567 May 22 '12 at 3:10

1 Answer 1

I've seen that before and the short answer is that you can only bind an SSL to a single IP and port that cannot be shared.

-Paul Drew

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.